How to save keyboard binds?

I can change keyboard input bindings for each system in the input menu but they don’t get saved.

How can they be saved?

1 Like

Had the similar situation some time ago when wanted to configure Typing of the Dead for Reicast, and needed to use the whole keyboard without binding.

Quoting hunterk from my topic:

“Unfortunately, hotkey binds can’t be saved in overrides (it’s just a quirk of how the input and settings stuff work). However, you can manually add a hotkey assignment to a core override using a text editor. Sadly, it will get wiped out if you re-save the override, but you can always add it back or set the override to read-only (but be sure to remember that if you try to save a new one!).”

So, add the keyboard binding line in the core cfg and set the file as ready only.

“So, add the keyboard binding line in the core cfg”

How do you do this? What’s the command?

1 Like

Check in your main retroarch cfgs (I am not at home so I dont remember if it was in the default one or the cores one). You will see there the input bindings. Just grab one of the lines, paste it in the core config and modify it with the key you need.

Ok, will try. Thanks for the replies

1 Like

Let me know how it goes.

1 Like


Sorry for replying to this subject but I can’t find how to open a new one… I’ve got a problem with RetroArch. I dowloaded it and tried to emulate a N64. Everything went fine 'til I wanted to play. I don’t know why but it doesn’t seem to see or find the arrow keys of my keyboard. I tried to follow the FAQ etc but nothing works…

Thank you in advance for your help.

That’s probably because N64 usually uses the analog stick for movement and that doesn’t have a keyboard bind by default. You can bind some keys in settings > input > port 1 binds (I usually map my numpad).

Hi all, I tried many ways to Save and have persistent HotKey binds. AN dthe only way I was able to get it persistent, even after retroarch reboots and new confirg saves, over rides is to add the values on the retroarch.cfg. and for good measure I also pasted my values in CORE and Folder Remaps and core cfg. IE NES.cfg and Nestopia.cfg (remaps on like nes.rmp) I think that last part is overkill, but I tried everithing and this is now working so overkill made it.
here are my confiig for my Ambernic rg351p running ARKOS?

input_hold_fast_forward_axis = “23” input_hold_slowmotion_axis = “24” input_rewind = “26” input_save_state = “20” input_state_slot_decrease = “h0left” input_state_slot_increase = “h0right” input_shader_prev = “h0down” input_shader_next = “h0up”

Hope it helps. The H0 values are for the left D-pad. That took a while to figure out.

You should be able to put them in the global config if you want them to apply all the time, but you’d have to copy them into any core overrides manually, since they’re invisible to the override system.

I don’t suppose they hurt anything in the remaps, but they shouldn’t be necessary, either.