How to stop RetroArch from changing my resolution automatically?

I have 2 screens, one 1080p monitor and a 4K TV. My main is the monitor but i also use RetroArch on the TV sometimes. But when i do that, RA automatically changes it’s resolution to 4K, despite having manually added 1920 x 1080 in the config file.

This causes some cores to slow down a lot. For instance, N64 with Parallel RDP crawls @ 4K. But because RA does this automatically, the only way to fix this is to manually go to the output settings and set 1080p resolution. Then everything is fine until i close the content and load something else. Then it gets at 4K automatically again.

How to stop this? I just want to use 1080p on both screens.

Seems like the custom resolution i set (1080p) is only for non-windowed mode fullscreen?

OK but if i use 1080p without windowed fullscreen i’m getting this:

So the only way to have a proper, filled screen at 1080p image is to load RetroArch, let it set 4K automatically and then go and manually change it from the output options. :frowning:

Is there a way to set a custom resolution for proper fullscreen as well? But also fill the whole screen properly? Seems like something so simple and basic but i can’t do that in RA.

video_fullscreen_x/y should apply whenever you load fullscreen, AFAIK.

video_fullscreen_x = “1920”

video_fullscreen_y = “1080”

This is how it looks in my cfg. And this is the rest of it: https://pastebin.com/ye90MuE5

As i said, it doesn’t work for me. If i use “windowed fullscreen”, it will change to 4k automatically. If i don’t use windowed fullscreen, it will only fill 1/4 of my screen, as shown in my post, but only on load. If i just change it manually while it’s open, it fills the screen properly.

I did some more testing and it appears like the reason the screen isn’t filled is because of the windows scaling settings. If you use anything other than 100% RetroArch will bug out like this. I tested this on a fresh .cfg.

This is a problem because scaling at 150% on my 4K screen is essential.

There is an option in the compatibility setting that should have fixed that. It’s the “override high DPI scaling behavior” option in the high DPI settings. If you change it to “application”, it fixes the problem in other games/programs that have a similar issue. There were a couple of games that had this scaling issue and that option fixed it.

Not with RetroArch though. It will never fill the screen, even with this option enabled. It’s still weird to me that there aren’t more users being affected by this problem.

Nobody else is having this issue?