HP ProDesk 400 G2 Mini + CRT 15Khz

Hello, I use this lovely little computer for Retroarch. I have another PC with an RX 580 + CRT Emudriver and I know how things should be. I know it’s not that easy with Intel HD, but I decided to give it a try.

Windows 10, WinModelines with resolutions:

Modeline “1920x240_60 15.7kHz 60.0Hz” 39.040 1920 1998 2181 2493 240 241 244 261 -hsync -vsync
Modeline “1920x480_30 15.7kHz 60.1Hz” 39.630 1920 2017 2202 2528 480 482 488 522 interlace -hsync -vsync

All emulators work perfectly, 240p and 480i, with some small exceptions, for which I am looking for help:

  1. I use 2 different CFG files for 240p and 480i because the resolutions don’t change when needed, why? (on my other computer when I run a PS1 game it switches to 240p, when I run a Dreamcast it switches to 480i.

  2. At 240p works: GL, GL1, Vulcan, D3D. At 480i only works: D3D. I noticed that in windowed mode the other drivers also work, but in full screen the picture blinking or the screen is black.

I also tried under linux: Lubuntu 22.04.2 + MME4CRT-Auto-Script 15Khz but Vulkan driver does not work. And I generally prefer Windows.

I would be very grateful if you could help me!

1 Like
  1. Sounds just like expected behaviour, RA doesn’t switch resolutions unless it’s specifically to set up to. I’m assuming you have either switchres enabled, or it’s somehow related to emudriver (which I don’t use), and some switching is occuring because of that.

2). Maybe it’s GPU driver related. I’ve run into some interlace problems with various setups. I never tried to pin it down to the RA driver used though.

I tried with linux Mint and finally things went as they should be. The picture is many times better than Windows, the resolution changes automatically when needed. Vulkan drivers work. Everything is great.

But again with one exception, which is very annoying: When a 480i resolution is displayed (for example on the PS1 splash screen) I wait 5-10 seconds until an image appears on the TV. Or when a game for example on SEGA Dreamcast loads and the screen goes black, I wait again for 5-10 seconds until an image appears on the TV.

I don’t know if the problem is from Linux Mint, but I think I’ll try again with Lubuntu, because this problem didn’t exist there, and I already know how to fix the Vulkan drivers.

It seems that, under Linux, there is no need to enter the custom resolutions, because retroarch itself changes them according to the cores. Every pixel is in its place and the picture looks really great!

This happens when I use NATIVE resolutions. With the super resolutions 1920x480, the picture appears much faster (2-3 seconds).

I want to ask if there are any advantages Retroarch under Windows, compared to Linux, because I’m hesitating whether to remove Windows or make it dual boot just in case? The only thing I saw is that there are no D3D divers under Linux? Will I need them for some emulators? Or under linux all emulators will work?

I installed only linux. I’ve been testing for 3 days and I saw that there is no need for Windows 10. I will describe what I have done to make it easier for others with Intel HD Graphics.

HP ProDesk 400 G2 Mini: Core i3-6100T, HD Graphics 530, RAM: 16GB DDR4, 1TB NVME + 1TB HDD, USB Wifi, USB Bluetooth, Sony Trinitron KV-29LS30E, Simple Homemade VGA to Scart cable

OS: Lubuntu 22.04.2 + RetroArch + 1 Custom Resolution and a few programs (RealVNC, Samba…)

After OS installation:


sudo add-apt-repository ppa:libretro/stable && sudo apt-get update && sudo apt-get install retroarch

Custom Resolution:

sudo nano /etc/X11/xorg.conf

and add:

Section “Monitor” Identifier “DP-3” Modeline “[email protected]” 39.147 1920 1998 2182 2495 480 483 489 523 interlace -hsync -vsync EndSection

Then restart and select the new resolution while the TV is on. I use RealVNC for easier.

Interestingly, Linux does not need any settings for 15KHz (it can even without custom resolution, but there will be no picture in Desktop environment)! The moment CRTSwitchRes->15KHz is selected in the retroarch menu, the picture appears on the TV in the correct resolution!

1 Like

Exactly, Linux doesn’t need any additional configuration, just activate the CRTSwitchRes and RetroArch does all the magic, all the automatic resolution changes from consoles to the most demanding arcade.

I always recommend you to read the Documents, it’s made with love and quite up to date.

RetroArch on Windows is no different than on Linux. Apart from the fact that DirectX has HDRi support, but I think Vulkan does too. Anyway, for emulation Vulkan is much better and Linux is much more expansive.