Intel HD 630 big performance difference with Windows

I was testing Linux Mint on my laptop which has 2 cards, Intel HD 630 and Nvidia GTX 1060 and i noticed a large difference in performance in Linux, at first it was using open source nvidia driver, when Retroarch running in Window mode the performance was on par with Windows, in fullscreen you could see frame dropping like no syncing properly or something (in heavy shaders like Guest.r-Dr.Venom, in light shaders it was running fine).

When i installed nvidia drivers, i got a new menu on toolbar with option to switch to HD630(power saving mode). So when i did switch to Intel, restarted etc, in window mode again performance was fine, when in full screen same with before, frame drops and not syncing. When using GTX1060(high performance mode) all go well, in Window and full screen. Perfect sync and performance is equal to Windows. Could Intel driver be the problem? How can i tell which driver it is using? I guess it is using some open source driver for Intel because i didn’t install any Intel driver and i don’t think nvidia would provide any.

I am using a Retroarch with .appimage extension if that matters.

Intel drivers in linux are usually top-notch. Nvidia doesn’t help with the open source driver for their hardware, so it has to be fully RE-ed and often has significantly worse performance than the official, closed-source driver.

In either case, running fullscreen should be manageable. Since it’s not, my guess is that it’s not getting hardware-accelerated at all and is using a soft-GPU, like LLVM-pipe. Is it dragging on your CPU in fullscreen, as well?

Now it’s using Nvidia closed source driver but I was curious because hd630 runs all shaders in windows even the heavier ones. When GTX1060 is used all run at extremely high speed (900+ fps on Guest.r-Dr.Venom same with Windows). Probably not using any acceleration on Intel scenario and i noticed Vulkan was even slower at this case.

Using gtx 1060 at all times is an overkill, battery life goes from 3 hours to 1 hour lol. Has to be connected to power source.

Cinnamon is a bit disastrous with applications that require special graphic composition.

Try to deactivate the desktop composition from the User Interface menu.

It seems to me that in the Cinnamon configurations there is also a desktop composition option.