[iOS/tvOS] mupen cxd4 rsp... and spongebob

Tried https://twitter.com/crashoveride953/status/1429148762287616011?s=21 and doesnt seem to work. Then tried in provenance with cxd4 instead of hle and it works.

Wonder if cxd4 can be implemented? Even If only to watch spongebob lol

cxd4 is already implemented. It’s the other LLE RSP aside from the ParaLLEl-RSP dynarec.

I only see hle for ios… unless im missing something

well, I don’t see the makefile setting LLE=1 for ios or osx, but I’m pretty sure osx has it… https://github.com/libretro/mupen64plus-libretro-nx/blob/develop/Makefile

FAKEDIT: oh wait, where did you even get this core? Our buildbot doesn’t seem to be building it for ios or osx.

So youre saying the option isnt there for ios or mac but it should be?

Got it either from weedys buildbot or still have an old version from the RA buildbot.

Yeah, it should be, since newer iDevices can handle it. If weedy’s able to build it, I’d be curious to hear how; if it’s from the old RA buildbot, there’s no way for us to update it since we aren’t able to build it for ios/osx on our current infrastructure.

Hmm darn well at least it seems it should be an option…

And yeah im not sure how @Weedy_Weed_Smoker compiled it. But you can see when under index extended, if that helps somehow

Also @hunterk i thought mupen wasnt being built purposefully because of the black textures issues not because it couldnt? I seem to remember reading that somewhere

Hmm, that git revision doesn’t seem to match up with anything around the build date… Not sure what’s going on there.

Just curious, why cant mupen build for ios/osx on the current infrastructure

@Trebrick @hunterk The version both YoshiSuga and I always compiled is the one modified by @jet082 : https://github.com/libretro/mupen64plus-libretro-nx/pull/123

The latest one can be compiled too, but it’s completely riddled with bugs and black textures!

1 Like

Took a look at the makefile… yah i see lle=0 for mac but dont see anything for ios. Wonder if its working on mac… guess i can try on my vm. But yah if its an option there hopefully it can be added to ios, either way no biggie… sorry spongebob