Is there a way to crop pixels over my monitor's resolution?

Hi guys. I’m new here and I don’t really know if this is the appropriate category to post, but I did try Googling this and using the forum search and I couldn’t find anything, so I apologize if this isn’t the right place for this question.

Anyway, I’m having a minor problem that’s probably more nit-pickying than anything else, but I figure there’s no harm asking anyway.

I’m was in the mood to play Street Fighter Alpha 3 and weirdly enough, it seems the most complete version of this game is still the PSP version. I do have a PSP and this game, but playing fighting games on such a small system is not really ideal, so I figured that, since it’s an enhanced arcade port, it most likely would look awesome with those fancy CRT shaders, and indeed it does. To my taste, the CRT-Royale-XM29Plus Vulkan preset looks perfect for this game, but than I stumbled on this issue:

The PSP has a 480x272, which is two pixels more than the standard 480x270 that would fit perfectly with a 4x internal resolution upscale to fit a 1920x1080 monitor. So the PPSSPP core, understanbly, only have the option for 1920x1088, or lower.

The problem is that if I set the integer scale to on (in order to make the CRT shader render properly and look good), I have to deal with black borders, as it won’t fill my whole screen, and if a set the integer scale to off, the shader won’t render properly, with uneven scanlines and artefacts.

So, after all this I was wondering if is there any way to set the PPSSPP core internal resolution to 1920x1088, but crop these 8 exceding pixels (4 up and 4 down?) and keep the integer scale on, so I’d have just a minor crop instead of huge black borders or incorrect shader rendering.

Here’s what happens because of the wrong scaling: https://i.imgur.com/BDhPMhU.png

I hope I was clear enough. Thanks in advance guys.

:slight_smile:

Sure. It’s easy but not automatic:

  1. go to settings > video > scaling
  2. set aspect ratio to ‘custom’ and integer scaling to ON
  3. set the custom height to 4x
  4. there may be a custom width integer that looks good. If not, disable integer scaling and adjust as needed. As long as you don’t touch the height, it should stay at its 4x integer.

Once you get it looking good, go to quick menu > overrides and save a core override to make it apply every time the core is loaded.

1 Like

Thank you so much! This will make things look so much better! Can’t thank you enough :smiley:

1 Like