Issue with core remap

I’m having an issue with a core remap on the MAME 2010 core with a Xbox 360 arcade stick. I have two of them, the first one remapped correctly. The second (as player 2) will not bind “Button 1” or “Button 6” (which correspond to Medium Kick and Heavy Kick) to any key, I tried them all. All the buttons work as I was able to bind jab to all six buttons and all are working. I also tried Mame4Droid and they all bind correctly, I’d prefer to use Retroarch though. Am I missing something here? Any help would be appreciated.

Nvidia Shield TV Pro Retroarch 1.7.3 MAME 2010 Core

1 Like

I deleted the core remap file and tried rebinding through the Input User 2 Binds menu. I still cannot bind Medium Kick and Heavy Kick, but can bind other actions to those buttons. Any ideas?

I tried Mame 2003 core and it’s working, so there is a bug in the 2010 core. Any chance of this getting fixed or should I download a new rom set?

You could make an issue at the core’s github repo, but I don’t know that anyone is prioritizing that core at the moment, so it may take a while to get fixed.

This was already fixed according to the GitHub, is the mame 2010 core up to date?

Looks like it built a couple of days ago, so yeah, should be.

@markwkidd, I noticed your name on the github. Should this issue still be present? Also, I’m getting a crash when attempting to change controls in the MAME UI.


Remapping for all buttons should be possible within the RetroArch controls menu, however I’m not too shocked that some functions aren’t working yet.

I have no idea what is going on with the MAME UI but if you can’t use the RA system to change those button assignments then please do file a MAME 2010 issue.

It happens without the remapping as well, meaning I’m just using the Input User 2 binds controls. Retroarch recognizes the input but its not binding to the action.

Could I just use the default.cfg to set the buttons? set the buttons in Mame4Droid MAME UI and transfer that cfg to RA?

MAME4Droid cfg files should be compatible. Seems plausible that it could work.

I know this is an older post, but this problem still seems to exist, so I am curious if anything new has been learned about this one. I am having this issue on Retroarch 1.7.7 Git Version 8c17f12., with standard usb controllers (Microntek USB Joystick driver). I have the appropriate romset for Mame2010, player one works great, player 2 cannot use buttons 2 and 6 which also equate to med. and heavy kick for me as well for fighting games. However the 2nd player controls work fine in MAME4droid, or even other cores in retroarch such as PCSX ReARMed. I tried a core remap file, and a game remap file which show all the 2nd player buttons acknowledged, just in game they do not respond. Also, I cannot open the Input options from the Mame UI, it crashes out of the application when I attempt to open these sections (either general or game specific), but other options in the mame UI work fine. I saw some other forum articles that button hard-coding may still persist but cannot seem to locate any proper cfg file to confirm that. The other recommendation at the bottom of this forum to copy over the cfg from Mame4Droid doesnt seem possible for me, as the cfg in Mame4Droid is empty (may use hard coded options as well).

Sorry, I am an new member so I can’t create new topics just yet. But have a question about remaps (i guess), Can you transfer control features found on a certain core and transfer them to another core in Retroarch Android? I am trying to see if I can get the “touchscreen lightgun” feature from MAME’s core to transfer to Flycast’s core so I can play games like House of the Dead 2, Ninja Assault, Extreme Hunting, ect.

No, a core’s input capabilities cannot be transferred to other cores via remaps.

Can I do it via any other way besides remaps?

Not through RetroArch itself. You would have to port the control functionality from the other core (i.e., with C/++), which may or may not even be possible/applicable.

So, is there a way to contact the RetroArch team to ask if they could add a “touchscreen lightgun” forthe Flycast core?

Yes, in this case, the best way to do it is to open an issue at the core’s github repo:

Put “feature request” in the issue title.

1 Like