Issue with Retroarch and Xenogears?

I posted about this on the emulation subreddit, and haven’t had any luck there getting an answer to this so I figured I would post here as well. I have recently started trying to make a switch from ePSXE to Retroarch. I wanted to play through Xenogears again, but I seem to be having issues that I can’t sort out the fix for. The game menu starts up alright and everything seems like it will be fine, but when I get past the first dialogue into the first in-engine cutscene of the game, it is extremely distorted and looks like this:

I have tried playing with all the different settings and things I can think of to fix this, but no matter what options I select, this is how it looks. I’m running Windows 10, I have 8GB or RAM, and a Geforce GTX970. Here’s an album with my current settings. Any help fixing this would be appreciated.

Try turning off options one by one and see if any of them keeps it from happening. The PGXP settings are the most likely culprits, but it could just be the Vulkan renderer itself.

Yeah, I’ve spent most of the morning doing that. PGXP was an issue when I had memory + GPU selected it was causing different problems. Once I went to memory only, it fixed some of those. But I’ve also tried OpenGL instead of Vulkan and I’m having the same issue. If I try to set it to Software with any of the other “improvements” selected, RetroArch crashes completely on launch.

1 Like

Hey, Made my account just to post this: had the same problem. If you go into the quickmenu, the one where you change frameskip, and disable frame duping, it should fix it. At least did for so for me :wink: hope this works!


I’m having the same issue. Easily worse when i’m in the underwater area as well. Can’t even playi it on Retroarch then. Looks like this: