Issues with RetroArch on a 4k TV

Hi,

Installed RetroArch 1.8.9 on my new windows 10 PC, it’s equipped with a standard AMD apu, ryzen 3 3200g and vega 8 iGPU, latest driver updated with the official AMD desktop app (Adrenalin). It runs great when connected through hdmi to my LG monitor (1920x1080) but it doesn’t work when connected to my 4k TV.

The problem is any core launched freeze at startup, while enabling some basic features like bilinear filtering, threaded rendering or scanlines crashes RetroArch. Tried with both Vulkan and GL drivers.

The TV is a LG 4k with hdmi 2.1 support, while the cable I used is an hdmi 2.0b.

I have tried with several TV settings: 3840 x 2160 (30hz / 60hz / 120hz) and 1920 x 1080 (60hz) but nothing seems to work. The cores just freeze everytime after a few seconds, some game running are able to display something but after a few seconds the screen freeze.

I have no problem for example with Steam and native games installed.

Thank you in advance, any help is very much appreciated!

Does the audio keep playing? That is, is the emulation freezing or just the image?

Unfortunately it’s a full freeze, and sometime it crashes.

I’ve tested it again a moment ago, after reinstalling RetroArch v1.8.9 but the core window just stop responding. I can give you some shots (taken from the TV) to take a look at the log file, output settings and windows desktop state.

As I said before, none of these issues occur while the PC is connected to a full HD monitor.

Thanks.

Weird. Have you tried using any other video drivers? d3d11, for example?

Haven’t tried yet, I will test it later, thanks.

Just in case it may be helpful, it’s a LG (C9, 2019) 65" OLED TV that supports 4K in 16:9, HDR, Nvidia G-sync, VRR and ALLM via hdmi 2.1

You can try this. Go to Video>Fullscreen Mode, and make sure to enable “Start in Fullscreen Mode”, and disable “Windowed Fullscreen”

I just managed to get it working with any core using gl/vulkan drivers, also while enabling threaded_video, bilinear_filtering and scanlines. I don’t exactly know how and why it works, but i have to do the following trick.

First of all, I had to enable all v-sync options, including adaptive sync and g-sync. Then, I have to launch RetroArch in windowed mode and start one of the cores (no one in particular). After the game load and run in windowed mode, I can safely turn on fullscreen mode and then it works just fine. From this moment on, I can start any core / load any game in fullscreen without issues.

But If i try to start RetroArch in fullscreen mode, any core just keep freezing.

Do you think It could be an issue with refresh rate of the TV?

1 Like

I have had this problem for weeks and I think I found that the issue lies with HDR.

When I disabled HDR through Windows for my TV I was able to boot into games. I haven’t tested every core but at the moment it appears to be working.

Best

1 Like

Thank you for the hint! I will try to disable HDR and see if this fix the issue with fullscreen on my Tv.

Also, I just found that if I disable audio or audio synchronization, I can launch RetroArch with any core in fullscreen mode: It works well, except any game runs at 2x speed.

Hey, I just wanted tag in and say i’m experiencing the exact same issue as OP with the same CPU. Works fine with no issues on a standard 1080p PC monitor, frequently freeze/crashes on cores when trying to play on a 4K TV with I believe most of the same features as OP’s (LG B8, 2019 65" OLED). HDMI cable used is also 2.0, unsure if a or b.

The only difference is that sometimes for me Retroarch did work for a while, especially if I launched it independently and tried to load a core (usually I use Launchbox) but eventually it would start crashing again no matter what I did if I switched to a different core or changed the PC’s resolution, stuff like that. I could fix it sometimes by restarting, or replacing/reinstalling retroarch folders with a program like stellar, though currently it just seems to be stuck crashing in all scenarios when the PC is connected to the 4K TV.

I’m going try some of the other methods mentioned in this thread and see if they work for me, just wanted to put forward that it’s not an isolated issue.

@deusX1 has this issue been resolved for you with no recurrence in the past 5 days? Just curious.

Dang, I got my hopes on this. I disabled HDR and turned off windowed fullscreen and like a charm, retroarch was working again. I tried several different games and cores and all booted up fine.

However, as soon as I tried to launch a game with Beetle Saturn core, I experienced the freeze/crash issue again. After that happened, all attempts to boot Retroarch had the problem again, even with games and cores that had been working moments before. Restarted the PC, same problem.

I don’t know if it’s right to pinpoint this on the beetle saturn core, but it definitely seemed to often be where things went south in terms of this issue when I was testing other options and fixes that also seemed work at first. The weird part is how it seems to influence the launch process for all the other cores if that’s the case.

UPDATE: So never mind about blaming the Beetle Saturn core. Something about the implementation of audio definitely seems to be causing the issue. I was finally able to reliably recreate the issue by turning audio sync on or off as mentioned in the earlier thread.

If Retroarch was in a crashing state, turning off audio sync would allow it to launch again. Of course, as already mentioned, doing this causes some games (Later 3D games for me) to accelerate. I’d also lose all sound once running one of these games and trying to play anything else.

Turning audio sync back on would fix that problem and again, things would be working fine until trying enough games, at which point the original crashing problem started again.

However, at the moment I don’t seem to have the crashing issue despite starting a bunch of different games in different cores. The only thing that happened was that some radeon process (I didn’t catch what it was) crashed and restarted while I was doing all this.

Still not sure what all that was about, but for now the problem seems to be gone. I’ll have to restart my PC and test few more time over the next several days and see if it’s truly gone for good or not.

Hi Dezmancer,

Currently RetroArch is running quite well, with only a few issues. In the end, I had to do the following settings:

  1. Set the display resolution to 1920x1080 60hz and disable HDR.
  2. Using GL driver, enable fullscreen mode, disable windowed_fullscreen, enable threaded_video, enable basic v-sync.
  3. Set audio driver to DSOUND (or OpenAL, SDL), because XAUDIO with audio sync ON made it crashes in fullscreen mode.

At the moment my issue is the crackling sound that happens sometime on some 3d cores (like beetle saturn) and some unexpected slowdown not happening with audio sync turned OFF. The issues are maybe caused by the audio driver, probably is also due to the refresh rate.

Interesting, shouldn’t these TVs be able to do 120hz at 1080P? I know mine is supposed to able to, but Retroarch is still detecting it as 60hz. Unsure if doubling the refresh rate would even fix the issue…

I’ve tried with 120hz with the aforementioned settings but games were running too fast. I will do more testing later today.