Issues with Save State from Quick Menu in Mupen64Plus-next

I’ve also posted this question to the r/retroarch reddit to try and find help on this. I’ve also nosed through the forums to see if I could find information on my issue but was unable to find any relevant info.

So I’ve been having an issue here lately and it’s more of an annoyance than an actual issue except in specific circumstances, but I don’t remember noticing it happening in prior builds so I honestly don’t know how to treat it.

The issue is this. When playing a game in Mupen64Plus-next (any game I’ve tried so far), if I use the Save State option from the quick menu, it makes the state and enters the “A”, or confirm button input. This is more of an annoyance than anything else unless i try to save state at a specific point in an RPG, it ends up finalizing my selection and moving forward with it instead of simply JUST saving the state and closing the menu where it becomes an issue. It’s almost as if it enters the input twice, once to make the state, and then accepts it upon closing the quick menu. I’ve tried nosing through settings to try and find what causes it and a quick google search turns nil, unless im using the wrong keywords.

I’m running RetroArch 1.8.9 (32 bit build), on the non-GLES 3 core for Mupen64Plus-next. Windows 10 64bit. Generally i use an XBOX One Controller for input, but it does it on keyboard as well.

Am readily available to provide any and all relevant information that may be needed to help resolve this if it’s indeed something that is, or needs to be resolvable.

Any troubleshooting information anyone can provide would be GREATLY appreciated at this point.

Log found at