Issues with Xbox One controller: Input from buttons "cut short"

Hi everyone,

I have a weird issue that I have tried to look for an answer here, but not been able to find anyone else having same issue.

So I am on nightly Retroarch latest version, everything updated. I have one Xbox One controller connected via USB. I don’t have Steam or any other controller related software running.

When I try to play either Castlevania SOTN (PSX) or Castlevania Order of Ecclesia (NDS) the input from my buttons is “cut in half” let me explain: when I try to jump by pressing (in my case) “A” on the controller the character on screen jumps as if I just quickly pressed the button, and does not register me holding down the button. This means that in both games I can only do a very short jump. As I can replicate this in both a PSX and a NDS game, I am guessing that it must be something wrongly configured with my controller (I haven’t done any changes to the controller configs, and it is recognized as a XBOX one controller, judging from the overlay notification that I get when starting a game.

Please help, as at the moment I can’t really play anything on Retroarch that requires an extended, uninterrupted button press.

Have you tried any other gamepad drivers? like dinput?


Thanks for quick reply:

Yes, I have tried all of the available drivers, and no difference unfortunately.