Lakka Add unsupported usb gamepads with no keyboard


#1

Scenario

Only got a laptop No usb keyboard around to navigate Gamepad not supported by autoconfig

But can access the sd card from a laptop

For windows you need a driver to read the sd https://www.diskinternals.com/linux-reader/ For linux and chromebooks it can be done out of the box

First boot up lakka with the controller plugged in. Watch the screen till you see a yellow text. We need the last 2 numbers from here. Try plugging it out and it and press any key to get the popup again

Download this file https://ghostbin.com/paste/jdrkg/download and replace

input_vendor_id = “Insert number 1 here” with the first number in this case 7511.

And input_product_id = “Insert number 2 here” with the second number in this case 32.

Rename the file to dummypad.cfg.

For windows enable show known file extentions to do this. Show extentions windows tutorial

12

Access LAKKA_DISK and navigate to the joypad folder. Create a folder called udev.

37

Copy dummypad.cfg into udev and boot up the lakka box. Navigate to input menu and map the controller. Save the config afterwards.

Idea here is to create a basic input device to navigate. Only dpad works and A and B. Just enough to start mapping. I can’t confirm this works with any usb pad out there, at least with mine it does. Let me know?


#2

Interesting.

Fortunately I have had all my gamepads recognized so I have not had this problem, but I would imagine for some this would make using Lakka a no-go.

Maybe in the future a feature similar to this method could be added so all unrecognized gamepads are configured with a basic config to at least try to enable navigation.


#3

I tried the following instead asking for specific device id ask for generic id with input_vendor_id “{star}” and input_product_id “{star}”

but drivers don’t honor this. Device has to specified with id’s. Unless there is a routine to pull this info into a cfg file I see no way to do it.