Layout bundles on Android phones

Hello all.

I tried the new layout features of 1.8.0 on my phone.

I downloaded a couple of layout bundles from the site specified in the release notes and extracted the zip files.

I then tried to load them using the new menu option but Retroarch keeps crashing when I do so.

Am I missing something?

You don’t need to extract them AFAIK.

It crashes even if I select the zip file (tested with Capcom’s 1943 bundle).

Ok, can you get a log of it crashing?

Sure. Could you please tell me where to find the log?

settings > user interface > show advanced options ON

settings > logging > log to file ON

it will then create a log in your ‘logs’ directory.

Got one. Does the “Info” verbosity level suffice? Do you need a “Debug” log? How can I send it?

Either should be fine, but may as well get a debug log while you’re at it. You can post it somewhere like pastebin.com or paste.libretro.com and then post a link to it here.

Done.

http://paste.libretro.com/170220

haha, that’s a huge log and only the last line really matters:

Unable to create FBO for video_layout

Okay, thanks for the log, we’ll see what we can do about it!

Thanks to you. Just let me know if i can help in any other way.

1 Like

I don’t know if this can be of any help, but I tried the same layout bundle (1943, taken from the site linked in the release notes) with the same rom on a Windows PC and it also behaves incorrectly.

Does not crash but the output is all black, until I pop up the in-game menu and disable the layout.

Hi guys, sorry for the bump about this long time but wondering if anyone knows how to fix this problem, or at least workaround it for the time being?

Getting the same problem described above. I’ve tried the latest nightly build and Retroarch in Android just crashes when one tries to use a Video Layout (whereas it works just fine on the PC version)

Can’t see a way to manually by-pass the error atm.