Libretro PPA for Ubuntu


#21

Attention to those who use the testing PPA (if you installed retroarch after dec/16/2014 disregard the information) Attention to those who use the stable PPA (if you installed retroarch after jan/10/2015 disregard the information)

Purge all your cores, make sure you don’t have any info file added manually to the /usr/share/libretro/info/, and then install all your cores again.


sudo apt-get purge libretro*
sudo apt-get install libretro*

Info files are not coming any more with each core package, there is a package now with all this info: libretro-core-info. So you need to purge all cores first and reinstall them, because the old cores in the system have the same file of this new package. Sorry for the inconvenience, this change was inevitable.


#22

Got it. Fixed and much appreciated for the information.


#23

A new issue has arisen, and I am not sure when it started as I haven’t launched Retroarch in about two weeks (but I keep up to date with testing). Today when I launched it the keyboard was not responsive for navigating the Retroarch menu. I tried deleting all configuration files and removing and reinstalling retroarch and all cores, but nothing has helped. I ran retroarch with the verbose switch and this is what comes up at the end:

RetroArch: parse_config_file: Found default config: /home/bruce/.config/retroarch/retroarch.cfg. RetroArch [ERROR] :: init_libretro_sym :: RetroArch is built for dynamic libretro, but libretro_path is not set. Cannot continue. RetroArch [ERROR] :: rarch_main_init :: Fatal error received in: “init_libretro_sym()”

Any ideas?


#24

That usually doesn’t actually mean much in my experience. Try adding --menu and if that doesn’t do it, add -c /path/to/config.cfg and/or -L /path/to/libretro.so


#25

Weird, I can’t get this error. Try to delete ~/.config/retroarch/retroarch.cfg


#26

Thanks for the reply. I did that. I actually deleted the whole retroarch folder in .config. It recreates it properly, but still I cannot navigate the menu at all. The program isn’t frozen as I see the clock is working, but I cannot navigate the menu at all now :frowning:


#27

What the ubuntu version and arch are you using? It can’t be reproduced in Ubuntu 14.04 64 bits at least, with the latest git version (Jan 23).

This libretro_path is the last core you loaded in RA, for me it’s libretro_path = “/usr/lib/libretro/genesis_plus_gx_libretro.so”. Try open your /home/bruce/.config/retroarch/retroarch.cfg and change your libretro_path entry with

libretro_path = ""

Are you sure you have the latest git version?


#28

I am running the same version of Ubuntu and same architecture. I was run ning the latest git, yes. I purged retroarch and all cores, removed the testing PPA and added stable. Reinstalled and that works fine with the menus. Something somewhere changed with the git.


#29

For those using Ubuntu 12.04 and Linux Mint 13, good news: we have packages now!

You need to install this PPA first, some cores were compiled with g+±4.9 (ppsspp, bsnes, tgbdual…), so they will need an updated libstdc++6 version:


sudo apt-add-repository ppa:libretro/gcc-for-libretro
sudo apt-get update
sudo apt-get install --only-upgrade libstdc++6

PS: this will upgrade an important component from the system, so be careful.


#30

Actually, it means that the ability to launch retroarch with a ROM via the command line without a wrapper script and have it autodetect rom type is now gone, and this is a regression in usability. This USED to be possible. Is there any reason why this functionality is gone, is it a bug, are patches welcome?


#31

To naxil from IRC:

RetroArch needs Multiverse and Universe repositories, so enable them and update, so libcg, libcggl and nvidia-cg-toolkit will appear.


#32

RetroArch 1.2 is in the testing repo, give it a try there :wink:

I’ll wait to the next bug fix release, then I push it to the stable.

Edit: Online Updater will only work for cores, assets, shaders, overlays and core info if you change the default path of them in Settings --> Directory Settings. I update these stuff regularly, so you can stay with the PPA packages instead. Don’t run RetroArch as sudo / super user.


#33

I just started a fresh install of my OS and now when i try to add sudo add-apt-repository ppa:libretro/stable it gives me

“plese check that the PPA name or format is correct”

can anyone help me with this

btw i am running on a Odroid if that makes any difference

thx


#34

The package “libretro-core-info” is not available in “wily” :confused: while it’s available on “vivid”.

Possible to have this with the other packages ?

Thanks.


#35

I’m updating the PPA, be patient. Take a look again.


#36

Thanks a lot :slight_smile:


#37

RetroArch has some issues with symlinks, if you are experiencing this (it’s recognizing Cores symlinks as folders), try change the Core Dir from /usr/lib/libretro/ to /usr/lib/x86_64-linux-gnu/libretro/ or /usr/lib/x86-linux-gnu/libretro/ (depending on the architecture you are using). Settings tab --> Directory --> Core Dir

There’s a debug package now for retroarch in the testing ppa, so you can get backtraces without need to build RA yourself.

I added a few more Cores in the testing PPA, like PCSX1, Stone Soup, Lutro and EightyOne.


#38

RetroArch package is updated to 1.3.0

Remember to delete the config file, since there is no more packages for shaders, overlays and joypad autoconfig files and the dirs were set to the root (now they are at your home). Use the Online Updater to download them.

rm  ~/.config/retroarch/retroarch.cfg

#39

I forgot to say: the recording feature is enabled now on 15.10 and higher, thanks to ffmpeg in the repos.


#40

I have no idea if i am doing anything wrong, but i am using Ubuntu Gnome 15.10, when i add the PPA, it goes through and i update the package list, but when i look in the ubuntu software center, none of the retroarch packages are found. If i do it from the command line, i get “package not found” This is on a completely fresh install.