Libretro realcd support


#4

I have seen this /complete sentence thing before.

I don’t get it?


#5

okay thanks guys for your answers, i originaly have planned to use lakka for my system but i think i’m will try with an ubuntu OS

Thanks !!


#6

There’s a minimum of 20 characters per post, so it’s just filler. That is, since “no” is only 2 characters, you gotta get the other 18 from somewhere…


#7

It should work, make /dev user readable, make a symlink “//games/cddrive.iso" -> "/dev/cd”,open the cddrive.iso.

This is only for linux, but I am assuming that this is a raspberry pi console hack and that you can handle root access.

This is reading you disk as just a giant rom file.

For any issues with this contact me at guicrith (email symbol) gmail (period) com since this would not be a retroarch issue anymore but an OS issue.


#8

hey thanks for your answer

i followed your instructions and created a symlink of /dev/sr0 (my device) to a iso file but it seems to work only partially

when in retroarch i try to launch the created iso the CD begins to be read, and in the terminal i can see that retroarch recognises the ps1 cd (the label i suppose) but after that it doesn’t acces to the gamedatas and after few seconds the cddrive stops and the game doesn’t starts stuck on a black screen

i don’t know it this issue is caused by the symlink or retroarch

do you have an idea about the issue ?

thanks a lot !!


#9

I dont know, I have never done this I just know an iso is a binary dump of a cd and that all hardware can be accessed as a file on linux, my guess is that retroarch does not have read/write permissions on the drive.

Try running retrorarch as root and loading the symlink.


#10

thanks for the time spend to help me !!

i have tried to run retroarch as root in order to run the /dev/sr0 symlink and the same happened i also tried to do a chmod 777 to /dev/sr0 and run directly /dev/sr0 i even tried with beetlepsx and the psxrearmed standalone that i’ve built (which not propose to run the cd either unfortunately)

sadly it seems that not possible to do that


#11

this will not work, since the cdrom code in the cores are make to read from these iso/bin/cue/ccd formats, they are not programmed to read or simulate from a physical cdrom drive.


#12

It’s not a ‘real’ solution, but what if you burned a bin/cue ON a disc?

Like, not burning it “to” a disc to make a copy of the CD, but just put the files on the root of a disc?

Then you could just point it to that disc’s drive letter like it was an external hard drive.

Hell you could even dress up the physical CD with a logo and everything lol.


#13

An ISO image is an archive file of an optical disc, a type of disk image composed of the data contents from every written sector on an optical disc, including the optical disc file system.

What is the difference reading the cd as binary data and dumping it to a binary file and reading that?


#14

The difference is what RetroArch is programmed to look for, if I’m not mistaken.

It’s setup to look for a file with a specific extension, open that file, and then read it’s contents.

A CD isn’t a file with an extension, it’s a directory; it can’t treat the directory as a file and then read it’s contents.

I’m sure it COULD be programmed to do such a thing, but I imagine that would take some heavy lifting from the dev team.

and honestly I’m sure it’s more complicated than this ^^^ but I can’t be too far off.


#15

If they linked it to a folder they linked it wrong. Try linking to /dev/cdrom

http://www.linuxjournal.com/content/copy-cd-or-dvd-dd

Dont copy it, this link is only here to verify that an iso and cd device file are the same format.


#16

They are in the same format but the fopen api works differently on devicefiles so they appear as 0 bytes and this freaks out retroarch.

You could make a shell script that does this.

dd if=/dev/cdrom of=/tmp/rom.iso retroarch /tmp/rom.iso

This dumps the cd to ram then tells retroarch to load the copy.


#17

you said above “symlink” then now its “dd” both are different commands and different things. OP does say he wants to use real cd, dd is just dumping a copy of the cdrom into an iso


#18

I know, retroarch cant handle a file of undefined size and that is what the device file is, so the cd has to be dumped.

But it can be dumped to ram instead of the disk and loaded from there, and if needed deleted when done.


#19

ahah it could do the illusion but if i show it to friends i have to hope they don’t bring their own games :smiley:


#20

yeah unfortunately i would like to avoid to dump because even if i put it on the ram the issue are the disks access, it takes more than 4 minuts to do a complete dump TT


#21

You make a good point.

I’m going to explore this idea further though. I started another seperate thread about it ““Fake” CD/Cartridge Support” See if I can’t flesh this out more.


#22

Any news here? I’m currently going through my PS1 collection and having to backup all games can get quite annoying. CD Drive support would be blessing. :wink:


#23

The update is that there is now a bounty going (contributors welcome!): Real CD/DVD read support

A few coders have looked at the issue but as far as I know there is no one who is working on new code yet. The bounty has only just started though, it may get a bigger and also may attract more attention over time.