Light Gun Games on Shield TV

lightgun

#1

I have a Shield TV(2015) and am referring to MAME2014, a NES and Reicast Core with games that use lightguns. I use a mouse with a cursor and mouse click for these games. Games like Duck Hunt, Terminator 2, and House of the Dead. on NES and MAME2014, these games kind of work but instead of the crosshair following the cursor, It’s somewhat off. I can’t get any kind of lightgun to work in Reicast core. I think Android RA uses only touchscreen without any way to properly set it to follow the cursor. I don’t know if I should add a GITHUB request or a Bounty request or anything like that. If anyone could tell me how to use a mouse cursor and mouse button press to work for lightgun games on RetroArch for AndroidTV, it would be very appreciated.


#2

I see if you go to settings/input/input user 1 binds there is an option for mouse index that may help


#3

what should this setting be set to and how should I know?


#4

I’ve tried many mouse index binds from 0 to 48 and nothing seems to make a difference. This effects all games that use a light gun or mouse. NES, MAME, DOSBoxsvn and the Mouse doesn’t work for House of the Dead on Reicast at all. Android seems to prefer touch screen, making the cursor wonky.


#5

whats the default input driver for switch? i think not all current drivers supports the new lightgun api (used to have a pointer api in fceumm because of this…)


#6

I think it’s an Android specific touchscreen hack in this file. -https://github.com/libretro/RetroArch/blob/master/input/drivers/android_input.c I don’t know how to get dev support.


#7

Im interested to see the outcome here. Shield owner and big fan of gun games. Just picked up an aimtrak for the pc. Gonna test that on shield at some point. These 2 threads may be of help @rclong


#8

ok if its using indeed the android_input, then it should support the pointer api (which is good for touch). the core you are using probably is using the mouse api which means its not touch friendly so youll have to press the screen, and hold it there and move while pressing the screen which is annoying way to play it. the driver also suppose the lighgun api but its the old one. this was why i used pointer api before in fceumm because its available in every driver but someone replaced it from there so touch devices dont work nice anymore with lightgun-type games.

you’ll have to open up probably 3 tickets regarding this, one for retroarch drivers to support the new lightgun api in shield driver/android, in whatever core you are using to use pointer api/new lightgun api for gun games


#9

Here are some test videos of games that use lightgun or mouse. -https://youtu.be/8UNNw1meTLo Area 51 (MAME 2014)

-https://youtu.be/1w0TiQVGZvM Command and Conquer Red Alert (DosBox svn)

-https://youtu.be/w8DIcPEAdgU Centipede (MAME 2014)

-https://youtu.be/ytlDbCmR-4g DuckHunt(forgot which core)

I couldn’t get Genesis or SNES to work.


#10

this is the normal crosshair behaviour if core is using the retro_device_mouse api (works on most drivers) if NES is using fceumm, there is an option there to use “lightgun” mode instead of mouse (just not sure if this api works for touchscreens, this used to use retro_device_pointer api which is more available in input drivers atm)…


#11

I don’t program, so much of this is lost to me. fceumm already set to lightgun, but it’s set to auto which works the same. regardless of the core, all of these videos show that the crosshair doesn’t follow the cursor. I don’t code so the android_input wasn’t a very educated guess. point is, I’m hoping something can be done to make the crosshair follow the cursor on Shield TV.

funny thing. I was messing with a apple track pad and a dolphin bar at the same time and I think I fleetingly saw dual mouse support. I could not replicate these results.


#12

tried beetle_PSX; justifier shoots but crosshair doesn’t move. GunCon does nothing. Other than that, still no progress.