Link Support Not Working with Sameboy

With link Support Added to RetroArch.

I can’t get to different Games loaded at same time to link with. I just get 2 Screens with same Game.

How do I be able get 2 games to run different games at same time

i am using Latest Offical Release 1.7.1 64 bit Version and I am Using Windows 10

Hi. Thought I would add my bit to this.

I’ve got Sameboy up and running with a different game in each window. (Pokemon GB2 in this case, though I’ve also tried Dragon Warrior Monsters 2). Both games run fine. When I try to set up a link between the two games the player that does not initiate the link freezes. The other player may or may not. In DWM2 both froze, in Pokemon GB2 I ended up battling a copy of myself!

I can get the link working with the TGB Dual core funnily enough but it won’t let me save the game!

Running both cores with individual roms works fine.

Am I doing something simple wrong?

Thanks for any help.

Hi. I’m in the process of uploading a video now but it may take a while (rubbish Sky internet :slight_smile: but I was reading the instructions again and saw this:

NOTE: You need to set the Filebrowser Directory to your starting point directory if you want to use the subsystem feature. It will not work properly without.

Does that mean anything terribly special. My file browser directory is set to the root folder of all my games. Thanks for all the help so far. Sorry for not describing it well :frowning:

Here’s the video. If you click through there is a breakdown of the various timings at the bottom.

I just read on the Launchbox Netplay tutorial that TGB Dual does link cable via netplay!

Have you Tried using a Different Version of Retroarch that has this Game Link in it?

Look for Latest Versions Here:

Yep tried again with the latest nightly.

Pokemon Gold / Silver: Fine Dragon Warrior monsters 2: One GameBoy resets, the other hangs Pokemon GB2: One GameBoy starts battling a clone of itself, the other hangs.

I’ll maybe try finding a list of GBC link games and try a few different ones.

Thanks for all the help and advice again.

Last post :slight_smile:

I’ve tried a few other s games (Monster Rancher, Tetris, Super Mario, Bomberman Quest) and they all seem to work fine. Tony Hawks was not happy and refused to accept that there was a link cable.

So I think I’ve just been unlucky with the games I’ve tried :frowning:

Thanks again.

I tried something last night.

That IF you load the Same Game Up then it will not work at all. Only Works when you have 2 DIfferent Games in the 2 Gameboys.

Video I made Here:

I guess Using the Same Game when Trading it kind of Stupid but IF you playing 2 Player with the game you can’t.

That what I found out last night

Okay I have Tried Pokemon Silver and Still does not work:

Here are my Saves IF you want to try them and see IF same thing Happens for You:

I’ve quickly run through 28 games. All using different ROM files, though some have used copies of the same ROM.

  • 14 seemed to work without issue. (Azure Dreams, Bomberman Quest, Pokemon Gold / Silver, Tetris, Super Mario etc)

  • 7 I’m not sure about since either I wasn’t advanced enough to try the link functions or I wasn’t sure what I was meant to do.

  • 8 Didn’t work. A mix of not detecting a link at all and almost detecting a link but not being able to get it to work. (Tony Hawk’s, Donkey Kong Country, Snoopy Tennis)

I didn’t test the Zelda games since I have no saves for them.

I know the numbers don’t add up but one of the games (Top Gear) ended up in a couple of categories. I’m not sure if it was working or not. The two screens did not really seem to match up.

I could upload the video but I don’t really think it is going to show anything. I can do a more thorough test and list the outcome if that would be of any use?

1 Like

Hi, me again. I see you two are onto another discussion :slight_smile: Here are the fuller results of my testing. Video will appear here when it has finished uploading.

From the description:

Using this list here:

I test out most of them in Retroarch to see if the link cable emulation works.

Game (Notes) Time

  • Azure Dreams (Working?) 00:00
  • Bomberman Quest (Working) 00:26
  • Bust-A-Move Mill. (Working) 01:06
  • Dragonball Z(Don’t know) 02:05 (Mis-titled)
  • Dragon Warrior 3 (Don’t know) 02:35
  • Dragon Warrior Monsters 2 (No) 03:17
  • Game Watch Gallery 3 (No idea) 03:36
  • Game Boy Gallery 4 (No idea) 04:24
  • Harry Potter (No idea) 04:35
  • Magical Tetris Challenge (Yes) 04:49
  • Mario Golf (Working) 05:46
  • Mario Tennis (Working) 06:30
  • Mickey’s Speedway USA (No) 07:06
  • Monster Rancher GB (Working) 07:55
  • NBA 3x3 (Working, glitches) 09:30
  • Pokemon Puzzle (Working) 10:42
  • Pokemon TCG (Not working) 11:24
  • Power Quest (Working) 12:18
  • Revelations Demon Slayer (Not sure) 12:46
  • Snoopy Tennis (No) 13:24
  • Super Mario Brothers (Working) 14:01
  • Test Drive (No) 14:33
  • Tetris DX (Working) 15:05
  • Tony Hawks Pro Skater (No) 15:39
  • Test Gear Pocket (No/Yes?) 16:07
  • Warlocked (Yes) 17:07
  • Yug-gi-oh (Maybe?) 18:00

The ROMS I used need ‘no introduction’ to other emulator fans :slight_smile: Most of the games that didn’t work either never detected there was a link at all or detected the link and then glitched in some fashion.

I did not try the Zelda games or other Pokemon games since I am sure these will be thoroughly tried by other people.

I would like to thank this testing process for introducing me to the game Warlocked which looks brilliant! Also I am finding Revelations Demon Slayer to be very, very confusing.

Thought I would test your saves with a bog standard 1.7.1 install.

  • Pokemon Crystal: This save displayed garbage text on my screen!
  • Pokemon Red vs Yellow: Worked fine.
  • Pokemon TCG: Nope, no joy :slight_smile:
  • Pokemon Silver vs Silver (using same rom at same time): Not working as in your video above.
  • Pokemon Silver vs Silver (using differently named copies of the rom file and adding a renamed save): Worked fine.

Don’t know if this helps.

1 Like

Thanks Mate

Is that you got with your Roms and Saves?

I got Red and Yellow Worked. TGC going by your Test Definitely Does not work


When I change names of Roms and Saves for Silver/Silver no saves sadly come out. How did you do that changing Names?

Did you try Yellow/Yellow and Red/Red Test?

Yeah Crystal is Weird as same thing Happens to me

re: saves -

I went into the retroarch\saves folder and just duplicated the save file for silver.

So ‘GBC Link Test - Pokemon - Silver Version (UE).srm’ beacame:

GBC Link Test - Pokemon - Silver Version (UE).srm’ and ‘GBC Link Test - Pokemon - Silver Version (UE) - Copy.srm

I renamed the ROM file in a similar fashion and loaded each into Retroarch. You need to make sure the filenames match exactly.

I did not test Red/Red and Yellow/Yellow. I would presume it would be similar to Silver/Silver.

Hope this helps.

1 Like

Thanks Tried but Sadly Comes up with no Saves just has New Game Option.

Took Pics of Files Here:

Got it Working It looks like as Saved same place but still won’t let me Connect with Gold/Gold

Video I made Tonight with me trying to get it to work:

This might be a bit late. But here is my save file set up. All I did was duplicate the .srm files and then rename the roms to match.

1 Like

Here what Happens with the Pokemon Games:

Pokemon Red:

Pokemon Yellow:

Pokemon Silver:

I am Pretty Sure I have Figured out now why it was not Working.

Last Night I was trying to get Mario Golf to Connect but Couldn’t until I tried using the Keyboard as I have 1 gamepad connected to both Gameboy 1 and 2. Then I tried the Pokemon Games using the Keyboard for Gameboy 1 and GamePad for gameboy 2.

I was able to link all the Pokemon Games going that way. Started with Accessing Trade/Battle in gameboy and once it got to Please Wait there I use gamepad to join with 2nd Gameboy and that worked for Each One Red/Yellow/Silver.

Though I did try Pokemon Trade Game that douglasamcintosh said did not work and I found the same thing even using the way it worked with other Pokemon Games

I did have two gamepads connected for my tests. I never use the keyboard. Gamepad #1 controlled the left. Gamepad #2 the other. Not sure if that helps you or not :slight_smile:

1 Like

I have a 2nd Controller I got a week or 2 ago. Should try that out.

But I tested again yesterday using Keyboard for Gameboy 1 and Gamepad for Gamboy 2 and still worked with Connecting with all the Pokemon Games I tried Red/Yellow/Silver though Gamepad can effect Gamboy 1 so Might be easier to use the 2 Controllers I have.

Just glad that I figured out that IF you are using save Controller/Gamepad that GameLink does not work