Linux-Portable Nightly discussion thread

Portable Linux nightly cores are now available. There is no solution yet for RetroArch, you should build RetroArch from source or from a PPA or community repository if available. The built-in updater will fetch linux cores from this location


Known issues:

  • Too early to tell

I’m having a strange issue on Arch Linux. When I try to use the updater to download a core, the core doesn’t appear in my /lib/libretro folder. It says it’s downloading but when i go to load the core it isn’t there. I can install and use the libretro-*-git cores from the AUR just fine, but the updater for the nightlies doesn’t work. any idea what might be causing this?

Well that folder is most likely not user writable, so you should change the libretro path to some place where you can write

Radius, what is the distro and gcc version used?

I’m having some trouble on ARM:

PicoDrive core is segfaulting, you need to compile it with make -f Makefile.libretro platform=“armv hardfloat armasm”

gpsp is getting illegal instruction, make platform=“armv hardfloat”

pcsx_rearmed: Error(s): /home/odroid/Games/RetroArch/cores/ undefined symbol: gteNCLIP_arm (I remember that the non-neon core have a problem, you should build it with make -f Makefile.libretro platform=“armv hardfloat neon” )

snes9x: I’m getting a black screen in any game.

The FBA cores seems to be wrong / does not match with the info files: it’s, not, the recipe is getting the source from the wrong repo.

Is this still the case?

I reset the OP so we can gather information from scratch, the thread is largely unmanaged atm

Side note, we need moderators and people interested on the different platforms to mantain these threads, update changelogs and try to channel issues. PM me or any other moderator if you’re interested.

I’ve just updated to the latest RA from the git I noticed a couple of bugs which I’m not sure are related to linux=portable builds I use. First of all, when RA is started, it prints these 2 lines:

Didn't read whole file: /sys/devices/system/cpu/present.
Didn't read whole file: /sys/devices/system/cpu/possible.

Also, I used to compile RA without networking and netplay but now it isn’t possible, make terminates with an error.

When I press SELECT+X quick menu opens but the problem is search also pops up so I then have to pres a button for the search to go away.

Hi, are you aware that buildbot for armhf seems to be broken? Latest core was built on 2015-10-06 19:02. There are many updates to cores since then & new cores waiting for build.

Bug report:

Is anyone still maintaining armhf linux nightly repo? It’s much outdated and many popular embedded devices use it in projects like Lakka / RetroArch / … - Raspberry PI 2/3, Banana Pi/Pro, CuBox, HummingBoard, Odroid C1/XU3/4, WeTek, Cubbieboard 1/2, Cubbietruck,…

Hello, a few months ago I have been able to enjoy the atari800 core for the linux platform in armhf neon, when formatting my steamlink, I have seen that in the core database, the core is no longer displayed or deleted.

Because it has been removed and it is no longer there?

I’ve used retroarch 1.7.4 with the updated databases, but from what I see on the website where the cores reside, it does not appear, a mystery.

Can not be added again?

I’m trying to run DS games on DeSmuMe Core, and is freaking slow, i usually play PSP games, even GameCube games emulated on my notebook, but DeSmuMe runs slow.

I tried change the configurations, but still the same

there is my specs

Linux Mint 19 x64 Intel Core i5 2.60ghz 3.6gb RAM 230gb SSD Intel GMA Graphics

Hi I am also looking to build for armv7l, docs are not entirely clear on the process. I can compile natively or cross-compile so if anyone has a starting point for that I would appreciate it.

hello, I was wondering if there is anyway to update Retroarch to the latest version on the pi?

I believe there’s a Snap package that works on RPi. There are also versions available in the PPA that should work, though you’ll probably need to download the deb directly rather than adding the PPA to your sources.list (that is, debian installations don’t always play nicely with PPAs)

ah. so what would be the best way to go about that?

go to the PPA’s website and click on “package details”, then click on the arrow next to the package you want and it will open up to show the different builds available:

would sudo - get update be enough to do it? or do I need to type a specific command line?

once you have the deb, you should be able to use sudo dpkg -i name-of-application.deb to install it. if you run into dependency problems, you can use sudo apt-get build-dep retroarch to get all of them.