MacOS Catalina issues

Hello,

Running RetroArch 1.8.2 on OS X Catalina w/ the latest point release as of Christmas.

I have discovered that some things aren’t working in Catalina. Specifically, loading anything from the User’s home folder. I haven’t triple-checked - [home]/Library MIGHT work, but anything in the Documents folder does not.

Starting in Catalina, Apple has split the main OS partition from the user data. That is, the main OS partition is now a read only volume, and all of the home folders, etc. are on an overlay partition of some kind.

I don’t have my MacBook handy right this minute, but when I do have it, I’ll post the partition mappings/mountpoints.

Symptoms are: when using the directories menu, several of the folders are not found. RetroArch thinks that my Desktop, Documents, and Downloads folders, etc. are empty. Finder shows they are not empty.

Strangely enough, if I move the RetroArch folder out of documents, and relaunch RetroArch, the folder is recreated again without incident. However, the UI still can’t access those files. (Game Controllers are unconfigured, Can’t find any Games if they are inside my home folder, etc.

As a temporary workaround, I have moved my Games into a disk image, and copied the contents of documents/RetroArch folder into another disk image. I mount these images before running RetroArch, and then change the directory browser to look for my stuff in the two disk images (inside /Volumes/[image name]/).

I will probably check existing bug reports and create a new one if needed when I return home.

This info will be more relevant to the Developers, and is not intended for everyday users:

[email protected] ~ % mount
/dev/disk1s5 on / (apfs, local, read-only, journaled)
devfs on /dev (devfs, local, nobrowse)
/dev/disk1s1 on /System/Volumes/Data (apfs, local, journaled, nobrowse)
/dev/disk1s4 on /private/var/vm (apfs, local, journaled, nobrowse)
map auto_home on /System/Volumes/Data/home (autofs, automounted, nobrowse)
/dev/disk0s3 on /Volumes/BOOTCAMP (ufsd_NTFS, local, noowners)
[email protected] ~ % diskutil list
/dev/disk0 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *512.1 GB   disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:                 Apple_APFS Container disk1         391.0 GB   disk0s2
   3:       Microsoft Basic Data BOOTCAMP                120.9 GB   disk0s3

/dev/disk1 (synthesized):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      APFS Container Scheme -                      +391.0 GB   disk1
                             Physical Store disk0s2
   1:                APFS Volume MBP SSD - Data          200.6 GB   disk1s1
   2:                APFS Volume Preboot                 78.9 MB    disk1s2
   3:                APFS Volume Recovery                528.5 MB   disk1s3
   4:                APFS Volume VM                      1.1 GB     disk1s4
   5:                APFS Volume MBP SSD                 11.0 GB    disk1s5

Did you ever get this resolved? I’m thinking about upgrading to Catalina, but I’ll hold off if RetroArch isn’t working properly. It’s good to see you at least got it installed. The download page has a warning that it may not install due to not being notarized.

Yeah, I never did figure out what they meant by “notorized”.

To answer your question, yes, I got it working. Although the problem was related to upgrading, it wasn’t exactly what I thought. The problem was in the RetroArch config file, not anything in the binary code. Something related to file locations doesn’t work quite right when you have RA installed on a previous version and then upgrade.

The solution is, after you upgrade to Catalona go to a terminal, and type “open ~/Library” then double-click on “Application Support”, then “RetroArch”, and then “config”. Inside, drag “retroarch.cfg” to your desktop, and then open reopen RetroArch. Please note: moving that file to your desktop will reset all of your settings in RA. You’ll need to reconfigure everything again.

I hope that helps.

Apple requires all software to come from identified developers from Catalina on.

Maybe Gatekeeper is causing problems, try to disable it: sudo spctl --master-disable, setup Retroarch and then re-enable.

Yeah, I wasn’t having a problem with gatekeeper. You can also bypass gatekeeper for a single application much easier, by right-clicking on the application in finder and selecting open, and then clicking open in the pop-up dialog. You only need to do this once for each app that you wish to run.

General reminder: RetroArch downloaded from the official site is safe to run. Everything else should be opened judiciously and cautiously when bypassing gatekeeper. Don’t just run everything you find willy-nilly.

You can bypass Gatekeeper for now. I’m concerned Apple may overreach in future updates and try to lockdown MacOS like they do iOS. Notarization is a step in that direction. Hopefully that won’t happen, but I don’t fully trust Apple on this one.

1 Like

Hello, how can I sideload RetroArch on Catalina? There are many suggestions in the thread. I get an error: Failed to open libretro core after opening content in RetroArch on iPhone. Thank you for help.

How did you get the OS to accept the download and run Retroarch? I am getting the system error and the nannies won’t let me run it…

I use iOS App Signer to sign the app and then sideload it via XCode. However I cannot run any content after opening RetroArch on iPhone.

@Thomas_xxxxx Did you try AltDeploy ?

I found out the problem. The problem is iOS 13.3.1. After downgrading to 13.3 the RetroArch works again.

Late to the party but is this REALLY a partitioning thing, or is it just that you haven’t given Retroarch access to those folders?

Apologies for piggybacking on this topic but as a new forum member I am seemingly unable to create new ones.

Retroarch works fine for me on Catalina except that I cannot seem to access ROMs from any of my external volumes in the file browser. I can locate them but get a ‘Directory not found’ message. Both volumes are formatted in Mac OS Extended (Journaled). Could this be why they are not showing any files? Should they be Fat32 or something? I’m basically trying to load ROMs from an external volume.

Any advice on solving this issue would be greatly appreciated.

I’m having the same problem as you. My files are stored on a FAT32 USB Stick, so formatting is probably not your issue. And I’m having what I assume is the same issue described in the opening post where certain folders return a “Directory not Found” message. First I tried running a rom from my Desktop folder, “Directory not found”. Then I tried the Downloads folder, same deal. Then I moved it to the Movies folder and that actually worked. Seems pretty random to me.

I also followed aaronouthier’s suggestion and deleted retroarch.cfg but unfortunately that didn’t solve anything.

Can confirm the same behaviour; /user/Desktop and /user/Download folders both return the “Directory not found” message. All of the other /user directories seem to work.

Yeah, deleting the config file didn’t solve anything here either. Guess I’ll try reinstalling.

This is weird; I’ve been moving ROMs that I want to play from an external drive into my documents folder to load from but suddenly now it’s returning the “Directory not found” error message. And this means it no longer locates bios files which are kept in the RetroArch system folder so I can’t emulate, say, PlayStation unless I relocate them. Very random behaviour.

Ok so I just did a clean reinstall of the latest nightly build and am now able to access all folders and external volumes. Crisis averted!

Welp, two weeks later and it has started doing it again. Can’t access external disks or random directories. Would this get more attention if I started a new thread or is this particular sub-forum just generally dead?

@untensuru You could just disable SIP (namely, System Integrity Protection)…

Restart while pressing cmd-R to enter recovery mode, open the terminal, type csrutil disable and press enter, then you can type reboot and press enter to restart again…