MacOS Nighties?

Any ideas when working MacOS nighties will be back on the buildbot? Right now only 4 MB files are built. Eagerly waiting for testing out an M1 build :sunglasses:

We’re working on getting our macOS runners up and functioning. No ETA but it shouldn’t be long.

1 Like

Many thanks! As the team wrote, these M1 Macs are quite amazing :star_struck:

I’m looking forward to it too. I noticed they are only 4 MB and it says they are corrupt/damaged when I try to run the application.

So nighties are here, testing now, thanks a lot!!!

Was excited to try out retroarch on mac again after I saw the codesigning and notarizing has been addressed. Here are a couple things I noticed. On macOS Big Sur 11.2.3, MacBook Pro 11,3 (intel i7-4960HQ with nvidia GT 750M).

RetroArch with Metal nightly 2021-03-13

  • rgui menu driver doesn’t seem to be fully supported (themes do not correctly apply, appearance options do not behave properly)
  • runahead does not work on beetle psx
  • show window decorations doesn’t work. probably more an issue with how macOS does window graphics. tried this option a couple weeks ago on windows and it didn’t work properly there either. would love if this feature somehow got implemented, I love how retroarch looks on my linux system using a tiling window manager.

RetroArch with OpenGL nightly 2021-03-13

  • can’t get any core to load. code signing still seems to be an issue on (see output below)
 ./RetroArch --verbose --config /Users/aoede/Documents/RetroArch/retroarchgl.cfg --libretro /Users/aoede/Library/Application\ Support/RetroArch/cores/fbneo_libretro.dylib /Volumes/Games/FinalBurn\ Neo\ Release\ Sets\ \(2021-03-03\)/arcade/
[INFO] === Build =======================================
[INFO] CPU Model Name: Intel(R) Core(TM) i7-4960HQ CPU @ 2.60GHz
[INFO] Built: Mar 13 2021
[INFO] Version: 1.9.0
[INFO] =================================================
[INFO] [Input]: Found input driver: "cocoa".
[INFO] [Core]: Loading dynamic libretro core from: "/Users/aoede/Library/Application Support/RetroArch/cores/fbneo_libretro.dylib"
[ERROR] Failed to open libretro core: "/Users/aoede/Library/Application Support/RetroArch/cores/fbneo_libretro.dylib"
Error(s): dlopen(/Users/aoede/Library/Application Support/RetroArch/cores/fbneo_libretro.dylib, 5): no suitable image found.  Did find:
        /Users/aoede/Library/Application Support/RetroArch/cores/fbneo_libretro.dylib: code signature in (/Users/aoede/Library/Application Support/RetroArch/cores/fbneo_libretro.dylib) not valid for use in process using Library Validation: mapped file has no cdhash, completely unsigned? Code has to be at least ad-hoc signed.
[INFO] [Core]: Content ran for a total of: 00 hours, 00 minutes, 00 seconds.
[INFO] [Core]: Unloading core symbols..
[INFO] [Video]: Does not have enough samples for monitor refresh rate estimation. Requires to run for at least 4096 frames.

Looking very good so far. Happy to have retroarch back as my main source for emulation on macOS now that I don’t have to disable sip anymore.

I just tried v1.9.1 (stable) and it has this problem. Unable to load any core.

Opened the following issue.