Mame 2003 & Mame 2003 plus cores bouncing back to Retroarch

It will be great if someone could help me as tried many things but I can’t sort this situation. Most of the times when I run an arcade game through Mame 2003 & Mame 2003 plus cores on Nvidia Shield pro it loads until the game’s menu and after a few seconds i get bounces back to Retroarch. The wierd thing is that sometimes it works when I reboot my Nvidia shield pro, but not for long as when I try to turn a few more games it bounces me back to the Retroarch menu. This situation happens only with Mame as other cores work fine. And since now I tried the following things

I uninstalled and I deleted all the retroarch data files and reinstalled Retroarch again 3 times without success.

Before installing retroarch on my Nvidia shield pro, I installed it on my brother’s Chinese Android box and everything works fine.

I uninstalled many apps to free my Nvidia Shield internal storage

I’m using a 256 GB 3.0 SanDisk micro pendrive for my roms

I noticed that Mame cores takes few seconds to run a game

I can think of 3 possibilities :

  • Some kind of memory leak, arcade cores can require up to several hundred MBs of available memory to launch games. Maybe your memory isn’t freeing properly for some reason, which would explain why it works after rebooting.
  • Android is a trash OS, and has a trash feature called “ANR” that will close applications if it thinks they take too long to respond. You mentioned it takes several seconds to launch a game so maybe that’s your problem here. Are you maybe using 7z archives ? I recommend avoiding that format, zip is dozens of times faster to read.
  • There is some kind of incompatibility between your android device and those cores on the games you are trying to play (i wouldn’t think that’s possible if i didn’t have to debug a similar issue last year on FBNeo).

Thank you for your reply if I’m not wrong all roms are in a zip format, I’ll be able to confirm it this evening. So why the same ROMs an unbranded Chinese Android box of my brother work fine? I was expected that my Nvidia shield pro is way better. If all the roms are in a zip format what can I do to fix this situation?

Nope, that’s not how it works with android trash OS, because every vendors will tune it their own way, which might be good or bad depending on your use case.

I gave other possibilities beside ANR, and i suppose ANR could be triggered by a lot of other things, like slow storage access, your underwear color, or whatever. Android is at that level of trashiness and stupidity : a decent OS should never close an application without asking the user first, or should provide easily accessible informations about the reason at the very least.

Which games are you trying to launch ? Did you try them in another arcade core like FBNeo ?

Since now I’m trying to launch 80s games such as Bad Dudes Vs Dragon Ninja, Vigilante, 1943, Xain Xleena, Carnov, all the Double Dragon games and a few more. I have all the Mame2003 ROMs with other 16 bit no intro full set ROMs on a SanDisk ultra fit 3.1 256GB pendrive formatted to fat32. No I have not yet tried FBNeo does it support all Mame 2003 ROMs?

I’m not sure if this is a coencedence as when I load a game with Mame2003 core once the game loads i immediately click on both start and select to access the Retroarch menu and i resume the game it does not bounce me back to Retroarch, but this is frustrating knowing that if I don’t access the menu once the game loads the game it will bounce me back to the RA menu.

I find it very strange that there is no solution for this, before posting here I tried uninstalling many apps as I was thinking that it could be lack of space effecting the ram on my Nvidia Shield or an app conflicting with RA. I also tried searching online and I could not find anyone having the same issues.

I am using geom shader on all cores.

Maybe I need to install an app cleanup such as avast? Too many apps running simultaneously can cause application to crash.

It supports the games it supports, including all the games you just mentioned, but the romsets might or might not be different from their 20 years older self. Read this if you are confused about arcade emulators, romsets and versioning.

Yes, maybe it’ll help, yet again my experience with cores crashing on android is that it’s totally random : 2 devices with similar specs running the same android version can behave differently, and a device with higher specs doesn’t necessarily do better.

1 Like

Thank you so much for your help. First I will try Avast app cleanup if it does not work I will reset my Nvidia Shield pro to factory settings so all data will be wiped from my Shield. So I will install RA from the beginning. The funny thing is I also have an Odroid XU4 and I noticed that some shaders such as Geom run smother on My Shield.

Solved I used Avast app to clean my Nvidia Shield and Mame2003 & 2003plus are no longer bouncing back to the menu when running a game

1 Like

Avast app worked only for a short time. I managed to solve the crashing issue by factory resetting my Nvidia Shield pro and installing Retroarch from the beginning.

I’m not surprised, as i said android is a totally unreliable OS.

1 Like

Until yesterday RA did not crash. However, when I tried to load The King of Fighters 2000 RetroArch crashed, after I tried loading The King of Fighters 2000 with FBneo and it did not crash. RA also crashes when I click on manual scan a folder with many ROMs and the second time scanning the roms does not crash. Is this normal with Nvidia Shield Pro?

Hi there firom Spain! Yesterday I became a new member in this forum and I can’t post at the moment. I can say that the same thing happens to me but with the FBNEO core. The game starts and after a few seconds It returns me to the menu of my android TV. I will explain it more extensively when I can open a topic, but what happened to you with the FBNEO as you mention? Regarding solutions, for the FBNEO at the moment I have not found, but the same thing happened to me with the MAME 2010 and MAME 2003 PLUS cores, and the solution that I have found although with a lot of luck I guess, it is to protect the core in information options when you load the core. With the games that happened to me from those cores, it hasn’t happened to me again.