Mame coin insert / select button

retroarch

#1

having an issue with some cores where the coin insert button is permanently tied to the select button it seems.

I’m using windows 7 in a full stand up arcade setup, using an IPAC4 board. (using keyboard inputs for the buttons) With retroarch. I have the select button and coin button set for different keys. In the Main controls bindings in retroarch as well as the in game core and game remaps. I have tried deleteing all the key maps. and using a setting other then retropad. The coin button will work fine, but whatever key is set to the select key will trigger a coin insert in some cores even if the select key is set to nothing in the game/core config.

It feels like the select key is hard coded to coin insert in some cores. but works fine in others.

First had select key set for “2” apparently thats a hard coded coin insert in some cores, it would trigger no matter what key was set to select. moved the select key to “y” and the coin insert would trigger, moved it to “.” and now the “.” triggers coin but not “y”. it follows whatever the select key is set to in the retroarch config. This happens on the fbalpha cores, seems ok on the mame cores.

can this be fixed?


#2

There are several different MAME cores. Could you be more specific about which ones have this problem?


#3

ok had to go back and check. mame2003_libretro, mame_libretro, mame2016 all have this problem. all of the fbalpha cores seem to be fine. although they are hard coded to the number keys for coins but at least they dont insert coins for the select key, so i can work with that.


#4

Some of the MAME cores read the keyboard directly while also simultaneously reading the keyboard input indirectly via the RetoArch retropad abstraction. That sounds like the kind of problem you’re experiencing, where you’re altering one set of bindings but not the other and it’s having erratic effects.

With this “simultaneous input” you have the same input being registered as the key itself by MAME and then as one of the various RetroPad buttons. As you remap in RetoArch the two sets of bindings fall out of sync.

mame2003-plus is the only MAME core I know of that doesn’t have this “simultaneous input” or “dual mapping” by default with RetroArch. If you already have mame2003/MAME 0.78 romsets, almost all of them will already work with mame2003-plus so it would be easy to give it a try and see if it behaves better. I suspect it will.


#5

This topic is why I signed up here, as I’ve looked around the web and am very confused on how to fix this for my situation.

I have a ShieldTV. Some of the controllers seem to handle select fine, while others it is very hit and miss. I think it might have to do with the back button needing to be long pressed at times and some race condition with that…not sure…

I’m trying to basically be able to run this without a keyboard (hence - shield TV). So any solution that says “just press 5 on the keyboard” doesn’t work for me. Has to be controller based. I can hook up a computer to it and edit a text file if need be, but I’m hoping I can just fix this in the retroarch/mame core UI, but so far my efforts have failed.

I’m on MAME core (MAME 0.197). I have a mame 0.197 romset, and I’ve gone ahead and added the Mame 0.197 system and bios files into the Systems folder, though I wasn’t sure if this was necessary. I’ve tried from the MAME UI switching the hotkey button to the mouse button that is located on the touchpad of the shield controller, but that doesn’t seem to help. I turned on “enable mouse for game” but again, no help. Ideally, I think I’d just move the insert coin to the Mouse 1 button the shield controller is sending out, but I’m not seeing a way to do this from the UI. Do I need to dig into a retroarch.cfg somewhere to do this?