Menu is running at 60fps when opened in game instead of 120 fps

Hey guys,

I have a 120hz TV and trying to run RA at 120hz also.

I have vsync enabled and vsync frame interval (or something called like that) at 2 so games run correctly even at 120hz.

The menu when opened from a game is reduced to 60 FPS and is a bit choppy. Games run at 120fps and when opening RA menu from desktop also runs at 120 FPS. Menu frame rate throttle is disabled.

Any idea?

I’ve been having a very similar issue the last few weeks as well. Not sure if the root cause is the same, but on my end, I’ve got it on a 60hz TV and usually running at 60fps, but once a game is launched, it drops down to 12-15fps in the menu. The game still runs fine.

Things that I’ve noticed in my specific situation:

  • In the past, this sort of menu stuttering has been present if Windows has HDR/HD Color enabled, but RA does not.
    • In this instance, HDR is enabled in RetroArch prior to the game launching, but is disabled and unavailable after the game has launched. This has not previously been an issue
  • The issue is somewhat resolved if any applied shaders are removed (menu framerates rose to ~30-40fps, but never achieved the 60fps of in-game)
  • Closing the content and going back to just RA sees the menu framerates return to normal

My specs:

  • CPU: Intel Core i7-8700K
  • GPU: AMD Radeon RX 5700XT
  • GPU Driver Version: 23.5.2 (I experienced issues with Vulkan on any newer driver versions than this)
  • RAM: 32GB
  • TV: 50" TCL 50S535
  • RetroArch Version: 1.16.0
  • Tested Cores (All cores except PCSX2 are their most current version from the Online Updater)
    • Dolphin
    • Mesen-S
    • mGBA
    • PCSX2 (self-built experimental version)
1 Like

Hey I just tried with or without shaders but it’s the same.

Talking about HDR I’ve never been able to make it work, screen just goes pitch black when enabling it (using Vulkan mainly but same with other drivers), I am able to set it to true in the cfg file then I can open retroarch menu in HDR but games won’t load and still give me that black screen.

I have my video driver for RA as a whole set to Vulkan, do you as well? If so, do you experience the menu issues with any other video drivers? I haven’t checked this myself, but I will as soon as I’m out of work.

If anyone happens to have GL set as their video driver, my understanding is that GL doesn’t support HDR, and this could be the problem if you can’t use HDR (although it could be something else… just one possibility)… I know this isn’t the point of this thread, but just wanted to throw this in.

Actually managed to use HDR after seeing some tricks of using dx12 to enable it and then go back to Vulkan but I don’t like the look of it is too dark

I have confirmed that the issue is present for me regardless of video driver, but I’ve also confirmed that apparently my issues stem from enabling HDR. Disabling HDR completely in RetroArch solved the issue entirely for me. Does anyone know if something was changed about how HDR was handled in 1.16 vs 1.15?

I keep HDR on in all the cores that allow it and I haven’t noticed any changes from 1.15 to 1.16. Probably not very helpful, but it doesn’t seem to be a global thing. I run Vulkan whenever possible.

edit I noticed in another thread you have an AMD card? I have nVidia so that might be one different factor.

Yeah, I’m thinking on my end it’s an AMD-based issue. I don’t have the issue on my main desktop, which uses Nvidia, but the only way I was able to solve both my Vulkan issues and my menu framerate issues was downgrading RetroArch back to 1.15 (HDR/menu framerate fix), and downgrading my AMD driver to a version from May (Vulkan fix).

Sorry I don’t know much about AMD hardware, but I hope you are able to get it worked out. Good luck.