Missing CRT SwitchRes menu?

I’m running Retroarch 1.8.8 with Retropie/EmulationStation. My CRT SwitchRes menu appears to have disappeared from the Retroarch Video menus. Do I need to do something to re-enable it, or am I missing it somewhere?

go to settings > user interface > show advanced settings and turn ON

1 Like

@redturtle Thanks, but I’ve already done that awhile ago. The menu still isn’t there.

If you are talking about RPI then this is a interface issue. A while back RPI was not compatible so it was removed from the menu. for some reason it was never re enabled.

@hunterk I know you guys are having a lot on your plate ATM. However, can you confirm this is still the case?

Just to clarify. You can still set the options in the CFG and it will work.

1 Like

Thanks, @Alphanu - is this the correct option for setting it to 31KHz mode?


:+1: I do believe that is the correct value to use

1 Like

@Alphanu I thought this only worked on the Raspberry Pi under X11?

No, I believe he changed it to not require X11 awhile back.

I had thought we made changes to allow the options to be visible without the X11 check but they’re still not showing on RPi for some reason, so it has to go through the config in this case, I suppose :confused:

1 Like

@hunterk is correct. This was changed a while back. Switching for RPi uses the RPi VCgencmd library which does not require X11.


@Alphanu @hunterk Assuming that Raspberry Pi uses dispserv_x11.c, then I think the #ifdef below is what’s causing the menu to get hidden? Do I have that right?

static uint32_t x11_display_server_get_flags(void *data)
   uint32_t             flags   = 0;


   return flags;
1 Like

ooh, yeah, could be. Are you able to verify and, if that’s the culprit, put in a PR?

1 Like

I haven’t done a Retroarch/Libretro build before, but I’ll look into it. Probably take a few days.


I’m running native Retroarch on an x86 PC running Manjaro, and the CRT Switchres menu is missing here too with advanced settings installed. Is this a bug? I’m sure it must be, unless the feature has been broken in some way and removed/hidden.