Missing SAVE/LOAD STATE options with latest GIT code

Hi there

Has anybody besides me tried to build latest RetroArch GIT code on GNU/Linux? The SAVE STATE and LOAD STATE options both seem to have disappeared. Tried deleting all my config files, etc.

Can somebody confirm this?

I still see them here.

Some reasons they might not show up include having hardcore mode achievements activated or a problem with the core info file’s savestate features lines.

For the latter you can go to settings > core (IIRC) and tell it to ‘bypass core info save states features’

Ok, thanks @hunterk

I had to enable that bypass core info save states features option in settings->core. But I have never disabled that: in fact, I had just deleted all config files (completely removed my .config/retroarch directory). So… isn’t it a bit strange that I have to enable an option to see the Save/Load State options?

that usually means there’s something up with your core info files. Are your info files up-to-date?

Can you believe that, after ten years using RetroArch (maybe more) and even coding video backends for it I didn’t know about those core info files? :blush:

Mistery solved, sir. Thanks a lot, specially for your patience…

1 Like

@hunterk BTW, even if copying over the .info files to ~/.config/retroarch/cores (and having verified that the core info path path points there), the SAVE/LOAD STATE options are not showing unless I enable the bypass option.

So, this core info file thing, does it need libretrodb or some other specific feature to be enabled in RetroArch at build time?

No, it’s purely from the info files, which just contain metadata about the cores (i.e., rather than hardcoding the information into RetroArch).

If, under the “libretro features” heading of the info file, it says “savestates = false”, the save/load options won’t show. Unless it’s true and the “savestate_features” is at least “serialized”, rewind won’t show, and unless it’s true and “savestate_features” is “deterministic”, runahead and netplay won’t show.

Oh well, enabling the bypass option works for all cores I use, so it’s perfectly OK now for me.

Thanks :slight_smile:

1 Like