Multitab doesnt work - no 4Player-Games to me?

Hello there, ive got a nvidia shield tv pro with retroarch on it. Everything works fine except multiplayer :frowning: every single button on evry controller is mapped from the main options.

for example i start retroarch and push a button on every controller to set them to a port. (retroarch shows the report controllers 1-4 is set to port 1-4) I use the same order to make it easier for retroarch i guess. :slight_smile:

So far so good… now i load bomberman (snes), go to the quick menu, choose “multitab” on the controller 2 device and be able to set the four player to “man”. I start a match, but only player 1 works fine. Players 2-4 cant be moved. I only can lay bombs, but not with all players.

The quick menu shows that all controllers button are assigned and i tried to set the controllers to various devices. - it is not working.

Edit: all controllers are connected via an usb-hub

Please Help best regards Jan

1 Like

Hi, i figuered something out. I deleted and reinstalled retroarch and did not the controller configuration in the main menu. Now i in the quick-menu (ingame) i can set the port 2 controller to multitab and play bomberman with four players.

But how do i change the bottons? In the quick-menu i just can switch working controller buttons, but want to set buttons of the controller i dont know the usb-code-number (i dont know the right word for that - for example: 107 (K.A.) )

How do i find out which numbers the buttons on the controller have to set the remap-files for the games?

ah, ok, it seems like your issue might be fixed by having working autoconfig profiles for each of your pads, so that when you connect them, they’re mapped properly to begin with and you don’t need to hard-map them in settings > input (which, as you’ve found, supersedes some of the automatic stuff).

When you connect the pads and press a button to set them to a port, does the notification popup recognize the pad or does it say something like “gamepad blah blah not configured. Using fallback”?

if the latter, you can make your own autoconfig profiles like this:

With just one pad connected, go to settings > input > port 1 controls, default all, map it, save the autoconfig profile, default all again, then close RetroArch. When you reopen it, it should recognize your pad and automatically apply your mapping. At that point, remaps etc. should still work on top of the profile. Now, do this for each of your unrecognized pads.

1 Like

@hunterk Thank you! SNES is working now, but N64 games do not (i tried two games). Player one works perfect, but the other players/controllers do nothing and when i opened the quick menu player one dont work also anymore. (Mupen64Plus)

The core Parallel 64 crashed retroarch back to desktop (nvidia shield main screen)

Strange that mario kart 64 works fine…

Any ideas? Maybe its the rom itselves?

hmm, yeah, if one ROM works, I don’t know why others wouldn’t.

Do they scan with the regular database scan (i.e., not the manual scan)? if so, we can rule out the ROMs themselves, since only known-good checksums will scan.

1 Like

I dont know what you mean. I got my roms on a usb-stick and put the folder in the options of retroarch.

Ok, i tried another rom and it is working now… What a ride…

1 Like

Another day another problem. In F-Zero X the A-button on my N64 usb controllers (N64 clones) doest work. mapping the A-button on a another controller button also doesnt work. The 8BitDo SN 30 usb and the logitech controller working fine.

What N64 usb controller (maybe a clone) could i buy that works perfect on retroarch?

Does it work in other cores? Does it work in the remote retropad? Does it work in other games? If any of those are true, it’s not a problem with the controller itself.

1 Like

Remote retropad is working

Parallel 64 crashed retroarch back to desktop

Mupen64Plus-Next GLES2 same as GLES3

But i can set the A-button to jump (switching A and B) but then the “B-button” dont work.

The A-button itselves is working but the games wont take the action for that button (in standard konfiguration)

Damn, i thought i got it. (F Zero X)

I mapped the button in a .rmp file and it works, but i have to load that remap file when the race allready started.

When i save that remap file and it will be loaded automatically by loading the rom, the controllers 3-4 wont work.

Very weird. I don’t know what would cause that :confused:

1 Like

Very weird is that no controller works correctly now. Although i didnt change anything from yesterday.

How can i reset all controller configuration without installing retroarch?

I tried to reset all controller from the menu, but it didnt work i guess…

open your retroarch.cfg in a text editor and delete all of the lines that start with “input_”

1 Like

Really? There are hundreds of lines starting with “input_”. Mostly with “nul” at the end (maybe its all resetted).

And i found a line: joypad_autoconfig_dir = “/data/user/0/com.retroarch.aarch64/autoconfig”

But in the folder /data/user/0/com.retroarch.aarch64 is no autoconfig file, is that correct?

Is there any option that overwrite something by closing retroarch?

F zero was working. All controllers was working perfect with my button assingnment. Also after closing the rom and starting again with autoload the remap file.

But after closing retroarch nothing is working exept controller 1.

Im patient, but now Im at the end


I have a solution to me. When f zero showing up the “press start”-screen i push the a-button on all controllers and the game works with all controllers…

i hope i will find out whats the reason for that is

1 Like

Last question. Which files do i have to save to get retroarch in my actual configuration again when it gets damaged or i have to reinstall for reasons?

retroarch.cfg, Game.rmp-files, Core.opt-files something else too?

retroarch.cfg, anything in the ‘config’ directory and anything in ‘saves’ and/or ‘savestates’. I think that should get all of the user-generated files.

1 Like

Hello There,

i got a problem again, but this time i have an issue with N64 controllers (clones).

I allready have two N64 controllers (clones) recognized as “generic USB joystick”, that work great.

Now i ordered another two N64 clones that recognized as “switch CO LTD., Pro Controller”

The problem with the new ones is, when i press the start-button i switch back to the home menu of the nvidia shield, no matter where i am in retroarch (ingame or menu)

Is there a solution for that, or what model of N64 USB controller (original shape) do i have to buy?

When I bought it, I made sure that the generic controller was in the description. I bought the suily USB N64 Controller.