My experience of RetroArch as a new user on PS3

Edit: Much of my rant here is no longer applicable as it was the result of trying to play on PAL 50.

Still loads of crashes and missing bits and whatnot, but it’s playable over HDMI or with a workaround, so my mind’s changed.

.

.

.

.

.

. Hi,

not sure if the PS3 port is still in development, but I thought I’d leave some feedback on how things went for me as a brand new user. I might be missing some really obvious stuff, but hopefully this helps others or gives the devs a noob perspective.

Process: Factory reset PS3 on 4.81 -> latest HFW 4.85 -> ps3xploit -> latest HEN -> latest RetroArch CEX via package manager

First oddity: the controls are wrong for GB, GBA, SMS, NES. On those consoles the ‘B’ (left most) button lies towards the tip of your thumb - Square ‘A’ (right most) lies on the ‘ball’ of your thumb in the name of ergonomics. Before, After.

Square is run on the SMB1, SMB2 & SMB3 SNES ports… so why not the NES? The precedent’s been set already. Your thumb rests in a certain position, and that position isn’t “let me rotate my wrist 90 degrees counter clockwise so my palm can mash the triggers”.

Just, y’know by this logic, why aren’t all of the SNES buttons rotated 90degrees so I can play the same SMB1-3 games on SNES/NES with the same button layout on the same controller if it’s so superior? Seems kinda juvenile and reeks of “well I like it this way, who cares that all the users will have to change this per core”. Bleh, being contrary for the sake of it?

Sounds like I’m making a big deal of nothing, but it felt to me like a bad omen. Had me wondering early on if there was some hot shot Axl Rose style Prima Donna leading development and imposing needlessly their preferences on others.

So anyway, I go to save the changes and find out that there’s no default directory for key mappings set. It’s showing … exit, file manager, make folder, set perms, come back… was a little annoying having to repeat this … for each core.

I assume certain folders probably have root perms and that’s why RetroArch is telling me the directory has not been found… while I’m in it. So back out, file manager, set perms, come back… Not sure if it’s odd coding or odd word choice?

So I loaded up a clean SMB1 ROM… Despite being fixed hardware I’m getting stuttering, choppy audio, a bad framerate, etc with the default core :expressionless: Disabling VSync and shaders kinda helped, still runs at sub 25 fps though. Starting to feel like I’m missing something. I understand that for general processing the PS3 is kinda limited (~800mhz Pentium) … but this game runs pretty well on NESTicle on Win95 (unfixed hardware), The PSP, the old XBox, the PS1 (for real it was actually a sweet emu), the PS2, Java! etc. Just a bit underwhelming, y’know?

I try a few other systems ( and of course have to set the correct button layout for each, kinda kills the fun the 8th time )…

Btw, it’s crashing every second game launch as it scans for new content. Just as the game starts with 0% right there on the screen. There’s no option with the terms “scan” or “content” to be found anywhere. I leave it for a bit, I’m sure I’ll find an answer eventually, but I’m starting to cringe a bit and scratch my head.

Later I try and launch RetroArch and it’s attempting to output 1080p over the composite cable. This of course crashes the entire system.

Straight into /dev_hdd0/game/SSNE10000/USRDIR and wipe the CFG

Bit of a Groundhog Day moment here: -re-apply the controls for each core -disable vsync etc again -still keeps crashing on every ~2nd game launch

I eventually disable playlists and that seems to fix it freezing on game launch. There’s no way this isn’t a known issue on a clean install. I have maybe a few hundred roms. Nothing crazy; just popular games for SNES/GENS/GBA/GB etc.

So eventually things are feeling kinda stable… I’m feeling positive. Yeah I’m not a negative person.

I try to load some NES games from .7z files… and mash X to get through… the system hangs. Despite having the NES header at the top of the file, it’s trying to open the game with arcade cores… is this normal? Does it take a wild guess from the .7z header, or does it try to look inside? Bizhawk has this down.

Later I notice GameBoy games are going into the overscan region… and off the side of the screen when I actually look properly. I can’t find a calibration option, so I try to toggle resolutions. It successfully sets 720x576 from an initial res of… 720x576. I scroll down 2 menu options and… it freezes the PS3 again.

I don’t want to be disparaging - especially given all the hard work that’s been put in, but all round it’s been a solid, thoroughly underwhelming “Meh”.

Honestly I kinda resent that so much hard work went into this huge unwieldy project instead of small, frequently-updated, competitive standalone emus. E.g. on the classic XBox there were several SNES emus each with distinct advantages. They all ran pretty well out of the box without issues and recompiling from source isn’t such a big task (not that you ever had to, mind). E.g. there are so many solid emus for the PSP which perform great and look good over component cables.

I guess it’s just a massive shame that things seem to be moving to PS4 already and this was left in a fairly unusable state compared to similar standalone offerings on the XBox or PSP scene.

Cheers!

2 Likes

Yeah, the PS3 port has been neglected for a number of years now. However, I can address a few issues:

1.) re: 2-button mapping, we default to the physical location of the buttons on the original console/controller. If you look at a Game Boy, B is cross and A is circle, so that’s how we do it. You can always move them around later using the input remaps (quick menu > controls), which you should be able to create automatically.

2.) re: stuttery NES, which core were you using? There’s not actually any “default” cores, so if one isn’t performing as you would expect, you should be able to try a different one.

3.) re: scanning, yeah, I believe the default behavior is to scan games on launch, and that causes problems on some resource-constrained platforms. We should probably just disable scanning and playlists altogether on most of the console platforms.

4.)

Honestly I kinda resent that so much hard work went into this huge unwieldy project instead of small, frequently-updated, competitive standalone emus

People work on what they want to work on. I assure you: most of the people that have worked on RetroArch would not have put those hours into working on standalone emus for a weird, hacked console. In fact, the reason the PS3 port has stagnated (and functionally degraded, as things like scanning and playlists have sort of left it behind) is because no one wants to test it, let alone work on it.

1 Like

My circa 2001 quality LP of SMB1 (playing one handed with my phone recording) with a slightly older PS3 build:

It runs fine. I have plenty of complaints about Retroarch, but NES games not working isn’t one of them. I show the options I have toggled, mostly in focus, at the end of the video.
1 Like

Thanks for that, looks way more playable! I’ll poke around older builds. Fail on the one handed flag grab tho :stuck_out_tongue:

Thanks for sharing your experience up there, it was helpful ! My self a new user here and run into some problems and was wondering if you have any advise to share Installed RetroArch successfully and have put my game roms on the PS3 internal HDD0, but not a single rom shows up. I tried several locations to place them with no success. In the folder assets and downloads they showed up but it crashed the whole thing. I created a folder called roms and placed it in the RetroArch directory as well,but they are not showing up there as well. Directory is empty it says. The funny thing is, the same roms are working fine and show up when I load them from dev_usb001 . Why ? Any idea ?

I saw you wrote something about file manager and perms, but not clear what you are talking about. Any help would be appreciated ! Cheers

Scanning is straight-up broken on PS3 right now, AFAIK. You have to use something like playlist buddy.

I can’t open new message/post so i reply one opened… RetroArch PSL1GHT…please remove it or make it functional. When opened, main meno enters in a infinite loop od moving down and nothing is usable.