N64 core locked at 50 fps


#1

Hey! Happy new year.

Let’s start this year with a “little” problem.

As the title already states is the mupen64 core for some weird reason locked 50 fps while every other is running fine at 60 and I can’t seem to find the reason why.

First of all my system: MSIX370 Gaming Pro Ryzen 5 2600x 16GB G.Skill DDR4-3200 4GB MSI GTX 970 Windows 10 Pro 64Bit with the latest updates.

So far I have tried every single core- and video option one by one to get up to 60 fps. No success. Checked every video related entry in the different .cfgs. Couldn’t find anything helpful either. I’ve tested older versions like 1.7.0 of Retroarch, but it made no difference at all.

I can already tell that it is not game related, because the drop from 60 fps in the Retroarch menu starts as soon as I load the mupen64 core. I’ve tested multiple titles and it’s everywhere the same.

In the last couple of hours I’ve tried three different NVidia Driver packages. From 399.xx to the latest. Checked with the NVidia Inspector if there was a fps limiter set.

Secretly I’m hoping it has something to do with the V-Sync problem that occurred with the last Windows update but it wouldn’t make much sense since it only happens on one core.

Slowly I’m getting out of ideas how I could fix that. Anything at this point would help me.

Thanks, Lexx


#2

If you disable vsync in settings > video, does it go up to 60? If so, is there tearing?


#3

Thank you for your answer.

The V-Sync setting has no effect. Nothing changes. Still locked at 50.


#4

ok, and if you hit spacebar? That should remove audio sync, as well, and let it run as fast as possible.


#5

Aren’t you using a PAL version of a game? Wich is locked to 50fps.


#6

It ran at about 450 fps. Was fun in F-Zero.


#7

that sounds like the 50 hz is the correct speed, then. As JHorbach1 suggested, is your ROM a PAL version, perhaps?


#8

That would be embarrassing if that’s the case. I didn’t think about that. Not at all.

Will check that right now.

Thanks to both of you.


It was the case. Problem is solved.