N64 NetPlay and Hat/Analog Gamepad

controller

#1

Hi there, I am using a RetroLink N64 USB Controller with RetroArch. It works great on the menu and it works great in both the Mupen64Plus core as well as the ParaLLel N64 core when I am playing single player.

As soon as I go to the main menu and choose “Start netplay Host” then the hat/analog control doesn’t work! I can use the directional pad and all the buttons but not the hat. Once I go back into the main menu and then click “Stop netplay host,” the controller is working totally fine in the game.

Things I have tried:

  • RetroArch 1.7.5 & 1.7.6, same experience
  • MacOS (10.14.3) RetroArch & Windows (10) RetroArch, same experience.
  • Both N64 cores Mupen64 and ParaLLel, same experience.
  • I tried the RetroLink N64 Controller and a Logitech RumblePad 2 Controller, same experience.
  • Tried starting/stopping Netplay BEFORE starting a game as well as while game is paused.

Is there something special I need to do to get the hat/analog stick working with netplay specifically? Again, everything works perfectly when I am not running netplay.

  • spiffyguy