N64 Retro-BIT Controller in Retroarch

I was superised but this controller doesn’t auto-configure well or even configure well manually. I’m playing Star Wars Shadows of the Empire and the two directional pads can’t be distinguished from one another. The ‘C’ buttons also provide a challenge and even A and B buttons don’t seem to do what they’re supposed to.

Anyone have any similar problems here or solutions?

Dang, i was gonna grab one of these. Are you using the USB version or the N64 version and an adapter?

Its the USB version. I ordered it and the NEO-GEO-X arcade stick from Amzaon at the same time. I thought I’d be returning the NGX stick but that configured manually quite nicely. I had success with the Sega Genesis controller by retrobit so I figured the N64 tribute one would go smoothly as well.

Is there a different brand that works/is easy to configure?

Yes i have one of the RetroLink N64 pads and on that its just the ‘B’ button that doesn’t seem to be assigned for games, in the menus it works fine however!

1 Like

I see. I get the feeling that N64 pads don’t configure well across the board. I wonder if there is one that completely works?

The N64 autoconfigs are all user-supplied, so there may be better ways to map them than whoever submitted the profile came up with. For example, some of them use double-mapping for one of the buttons so it performs the a needed menu function while also performing the competing in-game function.

The problem lies with the default mapping of the cores: they’re set up for modern layouts, with N64’s B and A being mapped to retropad Y and B, respectively, but if you map them like that, the menu controls are wonky, since they’re hardcoded to retropad A and B. IIRC, the double-mapping puts retropad Y and A on N64 B and retropad B on N64 A.

There’s also the “independent c-button mapping” option, which throws all of the N64 buttons onto digital retropad buttons for easier remapping (i.e., instead of having the C buttons on the right-analog and the C-button modeswitch on R2).

Either way, you’re probably gonna want to do some core remapping for it.

1 Like

This is all new to me though, core mapping in retroarch. All I’ve done to get controllers to work was just go into the port binds and configure there. Worked reasonably well for the sega 6 button controller and the NEO-GEO X.

So how do you do core remapping for the controllers?

load a core+content and then go into quick menu > controls > port 1 controls. You’ll see 2 columns, with your gamepad/retropad buttons in the left column and your core’s functions in the right column. You can cycle through the core functions using left/right to change what’s assigned to which physical/retropad button.

1 Like

Thanks. I’m running retroarch 1.8.7 and I believe if I do load a core + content does that you mean I am to bring up the actual game itself and then go into quick menu?

yes, that’s correct.

1 Like

Still not getting it to work correctly. I’ll upload some snapshots. Not sure if my logic is correct or not.

I was going to buy a N64 Retro-Bit controller too for Parallel64… Makes me think twice !

1 Like

I think this one is going to be a returner unless otherwise…

In the meantime, is there any N64 USB controller that can be configured logically in Retroarch just using the port binds?

I found this thread that might be heplful ? https://www.reddit.com/r/RetroArch/comments/aq17ax/having_the_hardest_time_getting_a_usb_n64/

I think its ultimately a returner since the directional pads can’t seem to be distinguished or set appropriatesly in any way. Makes a game like Star Wars Shadows of the Empire completely unplayable. At least from what I surmise. I’ll look over the reddit thread again but otherwise I think this one will have to go back. May try the retrolink one in the future as that one just seems to require a few simple tweaks if I’m understanding correctly.