Naomi Aspect Ratio Problem Flycast

I usually use Flycast for DC, but I opened Ikaruga with it tonight and there is a strange aspect ratio. I tried changing it in the Megabezel options, but they all looked “flattened”, as in this pic. I’m sure I’m missing something obvious, but can anyone tell me how to get this back to 4:3? Thanks for the help.

This is probably an interaction with the Mega Bezel, it’s trying to rotate the full viewport, make sure you have the allow core rotation off in the settings.

I haven’t had a lot of experience with vertical games on Flycast so this is just my best guess based on how it looks.


Good call. I turned off the allow rotation and then just had to rotate the tube in Megabezel and it’s good to go. Thanks! :+1: