Need Dolphin core general performance tips

I’ve been a user of regular Dolphin for a long time and can run games effortlessly on my current setup. However, I’m trying to use the Retroarch dolphin core to play Samurai Shodown Anthology with Retroarch’s CRT shaders, and the performance in-game is not quite full speed.

This is a bit puzzling because I’m running the game at 1X internal resolution, while I can run it at 6X on the regular build without breaking sweat.

Are there any basic performance settings for the dolphin core I should consider?

The biggest difference for me when using the Dolphin core, was setting stand-alone Dolphin exactly how I wanted it, and then copying it’s User and System folders over the ones RetroArch created.

Since that, I’ve not touched stand-alone. I get Gamecube bootup logos, and outside of some WiiWare titles, everything seems to work great.

2 Likes

Thanks. I did experiment with individual settings but that is definitely worth a try. I’ll check and see.

Well, it did not make any difference in the end. Ironically, this is a 2D game which doesn’t require that much power to run. Oh well.

Last thing on this: it actually runs better with D3D11 but then the slang shaders only show a black screen, and no other shaders are available.

You can try this. Go to Video>Fullscreen Mode, and make sure to enable “Start in Fullscreen Mode”, and disable “Windowed Fullscreen”

1 Like

Thank you for the tip, although I am already set up that way. I will initiate a separate topic to inquire about slang shaders not working for me with D3D11.

Not working for me. Resident evil, wiiware, several wii games are not working… just as an example.for me some configs are missing like gamecube controller in wiimode or shaking and IR functions for the remote

I wonder if the issue is hardware-related in your case, or perhaps the rips need to be verified. The game does work for me but it won’t do shaders with D3D11.

I have only verified redumps :smirk: And it is “port” related, as you can see in other threads

On my 8 years old PC I played Mario Kart: Double Dash!! with good FPS. Now on my new PC the FPS decreased a lot, impossible to play.

AMD Ryzen 5 3600 6-Core Processor
2x G Skill RipjawsV F4-3200C16-8GVKB (16GB)
Gigabyte RX 5500 XT OC 4G (GV-R55XTOC-4GD)

The cause of the slowdown was the driver of my generic joystick. I uninstalled the “SPEEDLINK STRIKE Gamepad” driver and installed the “USB Network Joystick”.

Device Name: Generic   USB  Joystick
VID: 0079
PID: 0006

Driver: USB Network Joystick

2 Likes