Need to change Retroarch config on Linux (Steam Deck)

The Deck is my first experience with Linux. I’ve installed Retroarch and after playing around with different video drivers to check performance the application will no longer open. I need to get into the .cfg file so I can manually type in the default GL driver but i’m having a hell of a time trying to find the file. I have found one called Retroarch.cfg but it just shows a few file paths for different things; it’s not the same as what i’m used to seeing on Windows. Can anybody point me to where i can find teh .cfg file? It’s the one that let’s you set in things like resolution and whatnot. Thanks!

It should be located alongside the executable in a subdirectory of the steamapps directory.

It’s like that in Windows but doesn’t seem to be in Linux. I downloaded it via the Discover window. I also downloaded via the website thinking it might be different but it just directed me to the flatpak one again. The only .cfg file I can find is in ‘files/etc/Retroarch.cfg’, but it’s not the correct one

dunno then. I don’t have a steam deck, but I asked the guy who’s been working on the Steam integration and this is what he said:


I’ve resorted to doing a factory reset. Can’t think of any other option. I found the exec file but it’s in a folder on it’s own.

The answer is /home/deck/.var/app/org.libretro.RetroArch/config/retroarch

you will find retroarch.cfg here.

If you install anything from discover - that’s the flatpak repository.

1 Like

I was going to post this. If you install RetroArch via Flatpak, it is not located in .config/retroarch as it usually does, but goes in the directory livedeht posted.