NeoGeo Issues

UPDATE: I placed the BIOS files individually directly into the mslug2.zip file and it worked. But this cannot be how this should be set up right? How should this be working?

Okay, Iv’e been at this for several hours over the last few days and I need another pair of eyes to help me through this clusterfuck.

I have:

  1. Downloaded at least 6 different versions of each neogeo.zip file
  2. I have placed this file each time both WITH the neogeo roms and inside the RA system folder.
  3. I have tried to open the rom i choose to test mslug2.zip in FBNeo, MAME2003, MAME2016
  4. I had assumed my sourced was a updated romset (see picture)
  5. I have meticulously checked the CRC of every bios file

Is there a tell-tale way to look into neogeo roms and at a glance know they are old and should be discarded? Or what sort of emulator would run the rom in the image shown? I have gotten this same rom to run in the past so its not corrupt, I would just like to know why this isnt working and what to look out for.

This is the BIOS file that was included in this particular pack. I have tried 5+ others.

Log portion. This is when trying to use FBNeo. Weird thing about this is the crc matches the file in the bios named “asia-s3.rom”. I copied this file and renamed it to sp-s3.sp1. Then proceeded to do all the steps again (bios in rom folder, bios in system folder etc) with no luck and the same error that that file was missing. Wut?

Core Info directly after trying a launch that should work. The bios that is confirmed to work (my copy-all-bios-files-to-thegames.zip-file half-ass method from the edit) is both in a neogeo.zip file inside the system and neogeo rom directories. Something probably super simple is wrong and I cant see it.

Solved. Basically the issue is a conflict between this option:

And FBNeo/RA ability to see the BIOS. i.e. if the bios isnt in the same directory as the direct game zip, nothing works. Is this fixable? :jack_o_lantern: I have games in their own folders in a zip for easier archival reasons down the line.

FBNeo will pick up BIOSes in system/fbneo, so you can put neogeo.zip there and it should pick it up.

Unfortunately not.

I tested this by confirming the bios I had works by putting the bios with the game.zip itself and launching working, then moving that bios from there to the system/fbnero directory, and it would no longer open the rom (Ive reset launchbox between launches)

I made sure to have the most fresh version just minuets ago.

[libretro WARN] [FBNeo] NeoGeo BIOS missing …

For now ive pushed the romset though the official DAT using clrmamepro and having the bios files be all integrated with each rom. This is not ideal as its over 3GB space wasted just for the neogeo stuff.

I made a bug/featurerequest report on the github. If anyone knows if im just missing a step, please let me know and ill close the report. Thanks

1 Like

I was able to reproduce the issue (i.e., system and/or system/fbneo didn’t work for me either), so I asked barbudreadmon about it and will follow up here if he tells me anything different.

My fbneo romset has neogeo.zip in it. The FBNeo core loads it just fine from the content directory.

The zip itself has these in it:

Archive:  neogeo.zip
TORRENTZIPPED-4A588A91
Length      Date    Time    Name
---------  ---------- -----   ----
131072  12-24-1996 23:32   000-lo.lo
131072  12-24-1996 23:32   japan-j3.bin
131072  12-24-1996 23:32   neo-epo.bin
131072  12-24-1996 23:32   neo-po.bin
131072  12-24-1996 23:32   neodebug.bin
131072  12-24-1996 23:32   neopen.sp1
131072  12-24-1996 23:32   sfix.sfix
131072  12-24-1996 23:32   sm1.sm1
131072  12-24-1996 23:32   sp-1v1_3db8c.bin
524288  12-24-1996 23:32   sp-45.sp1
131072  12-24-1996 23:32   sp-e.sp1
131072  12-24-1996 23:32   sp-j2.sp1
524288  12-24-1996 23:32   sp-j3.sp1
131072  12-24-1996 23:32   sp-s.sp1
131072  12-24-1996 23:32   sp-s2.sp1
131072  12-24-1996 23:32   sp-s3.sp1
131072  12-24-1996 23:32   sp-u2.sp1
131072  12-24-1996 23:32   sp1-j3.bin
131072  12-24-1996 23:32   sp1-u2
131072  12-24-1996 23:32   sp1-u3.bin
131072  12-24-1996 23:32   sp1-u4.bin
131072  12-24-1996 23:32   sp1.jipan.1024
131072  12-24-1996 23:32   uni-bios_1_0.rom
131072  12-24-1996 23:32   uni-bios_1_1.rom
131072  12-24-1996 23:32   uni-bios_1_2.rom
131072  12-24-1996 23:32   uni-bios_1_2o.rom
131072  12-24-1996 23:32   uni-bios_1_3.rom
131072  12-24-1996 23:32   uni-bios_2_0.rom
131072  12-24-1996 23:32   uni-bios_2_1.rom
131072  12-24-1996 23:32   uni-bios_2_2.rom
131072  12-24-1996 23:32   uni-bios_2_3.rom
131072  12-24-1996 23:32   uni-bios_2_3o.rom
131072  12-24-1996 23:32   uni-bios_3_0.rom
131072  12-24-1996 23:32   uni-bios_3_1.rom
131072  12-24-1996 23:32   uni-bios_3_2.rom
131072  12-24-1996 23:32   uni-bios_3_3.rom
131072  12-24-1996 23:32   uni-bios_4_0.rom
131072  12-24-1996 23:32   vs-bios.rom
---------                     -------
5767168                     38 files

@Paultimate it works properly here, see https://github.com/finalburnneo/FBNeo/issues/447

@RealNC From the content directory if the neogeo.zip file is in the same directory. Not when all of my games are separated into folders. Thats why its important that it also be able to get the bios from the system folder; it isnt.

@BarbuDreadMon I’ll try to get you logs/files you request soon after I update as suggested. Ideally Id be using Launchbox, but im doing this ‘manually’ through RA directly to remove a point of possible error. Basically this is happening:

NeoGeo roms should launch successfully if one or more is true, #3 is the problem child:

  1. The proper bios neogeo.zip are with the game files in the same set (the bioes files have been extracted and folded into same zipped game set using a utility (clrmamepro) (this makes for a lot of wasted space))
  2. The proper bios neogeo.zip are with the game files if they are all in the same directory (issues with separating by folders arise here if each game is then separated into their own sub-directories. This would mean a separate copy of neogeo.zip would need to be in each one of those directories, basically the same as #1, just with 2 files instead of 1, same wasted space)
  3. If a single proper bios neogeo.zip is in a central location used by all other emulators ive tested; the RA system or system/fbneo directory, FBNeo does not see these files and will fail to load them.

This poorly worded semi obscure setting actually means “System files only accessible in content directory”. This basically turns the system folder off.

(╯°□°)╯︵ ┻━┻ (¸.·´ .· ´𝓉𝒽𝑒 𝓂𝑜𝓇𝑒 𝓎𝑜𝓊 𝓀𝓃𝑜𝓌☆´¨) ¸.·*¨)

Why would you ever do that?

To encapsulate everything that I do with a particular rom into its own folder.

It seems you’re using the wrong romset for that :stuck_out_tongue: If you want per-game folders, you need a non-merged romset.

No, im using the correct one, with 0 roms missing. I dont think you understand, but thats not required. :jack_o_lantern:

I ended up getting it to work on my end after adding some missing files to my BIOS. I had been using a unibios and I guess it was pulling some of the files from elsewhere or something because once I got everything in there, it worked just fine from system/fbneo.

Well, if the BIOS files were missing from mslug2.zip, that means you don’t have the correct set because you’re using either a merged or split set. For your use case (one game per folder), non-merged sets should be used, as they provide stand-alone zip files where each game has no other dependency.

  1. Your romset is obviously not for FBNeo or mame2016, because the *.bin ending is pre 0.143
    This means mame2010 or prior (screenshot 1 you posted)
    Your log shows a different romset… ?
  2. Arcade cores are verry picky about romsets.
    For this you must using the right *.dat or *.xml to check if your roms are matching.
    Go to https://github.com/libretro and download the right datfile for your core.
  3. If your romset is lacking the information for which core it is made, then it will take a lot of time building it for the right core.
1 Like

For more info about merged, non-merged, split romsets, BIOS, devices, parent and clones you can read here:

Further informations about arcade emulation:

@ImnoTapLumber Good catch, looking at the content of mslug2.zip, it’s obvious the romsets weren’t validated with latest FBNeo dats.

@Paultimate That might not be an issue here since the files probably got renamed while the crcs didn’t change (and FBNeo only cares about crcs), but expect issues with hundreds of other romsets if you are using 10 years old romsets with FBNeo.

1 Like