Netplay issues I can't solve


#1

Hi there !

I’m using Retroarch since a long time now and I’m overall pretty familiar with it and never had too much problems I couldn’t solve by myself looking for answers around here, but I’m facing a couple of various issues right now with Netplay and didn’t found any answers anywhere about it…

So, I never really tried the netplay option before, I tried it with a friend some hours ago, and we faced quite a lot of problems.

We both have the same Retroarch version, same cores version, same roms, I can host a game, my friend can join, there’s no problems with that, we tried a few cores and I noticed some are apparently working better than others when it comes to latency or lag.

Bsnes Mercury Balanced - difficult to play, not much latency but weird problems, we played a bit of Mario All Stars and the jump button seems to be in autofire, if I hold the jump button it keeps jumping for no reasons, making it unable to do a full jump for example in some cases. Not sure if it’s because of latency…

Mesen - Just a quick try, but it worked perfectly on my side, unfortunately, my friend was unable to do anything. No problems to see me playing, but he couldn’t play as player 2 for some reasons. No problem when he plays solo, he also is recognized as player 2 when he joins the lobby, but he just can’t move beside that. Controller working without problems to pause the game and navigates in menus.

Genesis plus GX - Same as above, perfect for me, but he can’t do anything.

The controller not working is the biggest issue, but there’s another one related to all three cores we tried: my friend had no audio at all during all games we tried, I can’t understand why. Once again, no problems for him when he try to play alone, either soundwise or about the controls.

I tried to find answers but most problems are related to connections, didn’t see any mention of these problems online so I don’t know if we did something wrong or if we are using cores not good enough for online play (I found threads mentionning players using Gens Plus GX for netplay so I guess that’s not the reason).

We couldn’t try the other way around (me joining his server) to see if I encountered the same problems but I’ll update this thread when we will have the possibility to try this.

Right now, if you can help me to sort this out or if there’s any good and complete tutorial you can recommend to setup netplay, I’d be glad to know, I checked as many as possibles but once again, these problems were not mentionned, here’s why I’m directly asking here.

Thanks for the help in advance and thanks for the hard work you’re doing with Retroarch ! :star_struck:


#2

Not all of the cores play nicely with netplay, which involves taking savestates every frame and skipping about among them when desyncs are detected. The cores you mentioned are, unfortunately, not great for it.

The most reliable ones are snes9x for SNES, picodrive for MD/SMS/SCD and FCEUmm for NES. FBA is also quite good at it, depending on which games you’re trying to play.

A good rule of thumb is: if it works with runahead, it will probably work with netplay and vice versa, since they do similar things (runahead is basically just netplay without the ‘net’, where any input is treated like a desync).


#3

hmmm… been troubled about NES (fceumm/quicknes) missing effects for actions when pressing buttons (jump, fire etc). might be related. and these cores works so far in 1-frame runahead(which was how i initially expected netplay to work)


#4

Thanks for the quick answer and cores advices !

We’ll try with these ones next time, I wasn’t aware what to use so I picked my fav ones when playing solo but I was kinda sure there was better options of course.

Does the sound and controller not working problems for the client connecting sounds familiar to you beside that ? I can’t tell if it’s core related or not right now, I need to try more options, I’m just trying to figure out possible clues about parameters not properly setup for now.


#5

Not sure. I’ve heard people report that sporadically, but I don’t know what causes it, be it wrong cores or something else.