New gamepad autoconf process


#61

Does your controller work on android standalone emulators?


#62

im not sure, the only time ive used it was on retropie on the raspberry


#63

i was looking around all the autoconfig files and there is one that looks like it matches with my controller but its in a folder marked “udev” its the dragonrise “gamepad” cfg. I dont know if I can use that with android or how i would go about it. I tried pointing my directory at it, but nothing happened. i think im doing something wrong.


#64

Android can only use drivers from the ‘android’ folder. If there’s not one in there, you’ll have to set it up on your own and then hopefully submit your android autoconf profile for others to benefit from.


#65

so i found the match for my controller in github but i dont know how to get it in my device or if it will even work here is the info. this is the copied path. retroarch-joypad-autoconfig/udev/[B]DragonRise_Inc._Gamepad.cfg and the file looks like this: [TABLE=“class: highlight tab-size js-file-line-container”]

input_device = “DragonRise Inc. Gamepad”

input_driver = “udev”

input_vendor_id = 121

input_product_id = 17

input_b_btn = “2”

input_y_btn = “nul”

input_select_btn = “8”

input_start_btn = “9”

input_up_axis = “-1”

input_down_axis = “+1”

input_left_axis = “-0”

input_right_axis = “+0”

input_a_btn = “1”

somebody please help

[/TABLE] [/B]


#66

ok, but the main and number one problem is i cant get past the first couple steps because when I hit User 1 bind all my controller is not recognized, just my keyboard and mouse are. Does this have something to do with the fact that im on a riotboard and have 4 USBs? I found the cfg for my controller in the UDEV folder (at least I think its for mine, everything looks right) Im wondering if i can use that one? if so how? ive been stressing for days trying to get this controller to work… i have a bunch of roms imported in that work fine with the keyboard but we all know the keyboard sucks for classic NES games… so if anyone can help i would really appreciate it :slight_smile: oh i just saw somebody answered a previous post… so i cant use the udev cfg… but how can i edit it?? or how do i make my own?? i cant figure out that key test app if it involves that maybe someone cann help.


#67

What you need to do is figure out what keycodes your controller puts out, which is where the key test app comes in. Once you get those keycodes, you can plug them into an existing config for some other controller and replace the vendor_id and product_id with the one from your controller.


#68

but the key test app doesnt appear to do anything…at least i dont know how to use it. its just a “hello world” app and doesnt seem to do anything. Also, the USB host viewer app gave me my vendor_id and product_id, so couldnt i just use those? Or you could just tell me how to use the key test app and what to do from there… i would sooooo apreciate it!


#69

Dunno, never used it myself (I don’t really do any emulating on Android), but you might have better luck with something like this:


#70

Retroarch 1.34 stable works fine in OUYA, but is very hard to setup because there is no response from the gamepad and I can’t tap the touch pad in XMB menu either, so the way to configure right is edit the retroarch.cfg file and change the line menu_driver = “xmb” to menu_driver = “rgui”, now with the classic looks you can tap the touch pad and setting up the OUYA gamepad.

Retroarch 1.34 (and nightlies version) won’t recongnize at all the OUYA gamepad, because the old autopad config file OUYA.cfg has a different parametes for the pad, so when I save the new the name changes also for the file and goes to OUYA Game Controller.cfg.

the parameters inside the new file change as well:

input_driver = “android” input_device = “OUYA Game Controller” input_b_btn = “96” input_y_btn = “99” input_select_btn = “106” input_start_btn = “107” input_up_btn = “19” input_down_btn = “20” input_left_btn = “21” input_right_btn = “22” input_a_btn = “97” input_x_btn = “100” input_l_btn = “102” input_r_btn = “103” input_l2_btn = “104” input_r2_btn = “105” input_l_x_plus_axis = “+0” input_l_x_minus_axis = “-0” input_l_y_plus_axis = “+1” input_l_y_minus_axis = “-1” input_r_x_plus_axis = “+2” input_r_x_minus_axis = “-2” input_r_y_plus_axis = “+3” input_r_y_minus_axis = “-3”

enjoy! :slight_smile:


#71

Latest Google play store Android version Xbox Wireless Adapter config file. I used the Micosoft Xbox 360 Controller config as base. I did not see any autoconfig file for the wireless Xbox controller (at least not in the directory autoconfig/android): (Sidenote: the bold text is probably wrong in the Xbox wired USB controller config)

Where is the user genarated config file located anyway, so i can double check below config.

input_driver = “android” input_device = “Xbox 360 Wireless Adapter” input_device_display_name = “XBOX 360 Wireless Controller” input_vendor_id = “1118” input_product_id = “1817” input_b_btn = “97” input_y_btn = “100” input_select_btn = “109” input_start_btn = “108” input_up_btn = “h0up” input_down_btn = “h0down” input_left_btn = “h0left” input_right_btn = “h0right” input_a_btn = “96” input_x_btn = “99” input_l_btn = “102” input_r_btn = “103” input_l2_axis = “+6” input_r2_axis = “+7” input_l3_btn = “106” input_r3_btn = “107” input_l_x_plus_axis = “+0” input_l_x_minus_axis = “-0” input_l_y_plus_axis = “+1” input_l_y_minus_axis = “-1” input_r_x_plus_axis = “+2” input_r_x_minus_axis = “-2” input_r_y_plus_axis = “+3” input_r_y_minus_axis = “-3” input_b_btn_label = “B” input_y_btn_label = “Y” input_select_btn_label = “Back” input_start_btn_label = “Start” input_up_btn_label = “D-Pad Up” input_down_btn_label = “D-Pad Down” input_left_btn_label = “D-Pad Left” input_right_btn_label = “D-Pad Right” input_a_btn_label = “A” input_x_btn_label = “X” input_l_btn_label = “Left Bumper” input_r_btn_label = “Right Bumper” input_l2_axis_label = “Left Trigger” input_r2_axis_label = “Right Trigger” input_l3_btn_label = “Left Stick” input_r3_btn_label = “Right Stick” input_l_x_plus_axis_label = “Left Analog X+” input_l_x_minus_axis_label = “Left Analog X-” input_l_y_plus_axis_label = “Left Analog Y+” input_l_y_minus_axis_label = “Left Analog Y-” input_r_x_plus_axis_label = “Right Analog X+” input_r_x_minus_axis_label = “Right Analog X-” input_r_y_plus_axis_label = “Right Analog Y+” input_r_y_minus_axis_label = “Right Analog Y-”

Another sidenote Retropad with analog does not work. If I use the option analog to digital right or left, both work sperately. So probably a bug?


Xbox 360 Wireless Receiver (1118/1817) Not Configured
#72

RetroPad with analog doesn’t work with which core?


#73

I have not tried any core yet. You can’t scroll the menus using both sticks if you have retopad with analog enabled. It does works if you use the option analog to digital left / right.


#74

It’s not supposed to work with analogs (the menu)


#75

So far I tested SNES (SNES9x) GBA (mGBA) and NGPC (Mednafen) Sticks don’t work, but I suppose they don’t need to for those cores. Can anyone submit my config to github?


#76

What for? it seems to be working as designed. Try setting Analog d-pad mapping to left stick or right stick to confirm they are working as desired.


#77

My wireless Xbox controller auto config file I mean. It is not available in Android autoconfig. Also you can’t configure the D-pad using manual input. It is being regsitered as 0 and you can only use the D-pad up button then.
Both sticks work fine if I use the analog to digital option. Nothing wrong there.


#78

help how do I use xbox360 wireless

Navigate to settings / input / user 1 input binds Select user 1 default all Select user 1 bind all Select user 1 save autoconf Select user 1 default all to clear the hard bind from the config

only left thumb works and dpad + buttons is this normal for right thumb not to be workings also noticed that dpad up,left down, right are all “0” keys?


#79

Seeing I cant see any way to start a new thread…

Having a devil of a time getting controllers to work on Android. This is on a variety of Android TV boxes. Now on the model I deal with mostly I have tested official PS3 controllers, Rock Candy 360 controllers, an old Microsoft Sidewinder pad and they all work. Even my old USB adapter for PS1 controllers, I plugged that in and it works. But I just tried the girlfriends other third party 360 controller, and a friends third party PS3 controller and some others wont work at all. I can navigate the rest of the OS with it, but in Retroarch I cant do anything. Not even with a keyboard or mouse, just nothing. Keystrokes and clicks dont respond inside Retroarch, so I cant configure anything unless I have one of the controllers types I’ve tested and even then it can be iffy. The touch screen option described above isn’t an option either. Is this a known thing? Any fixes? Talking Android 4.4, 5.1 and 6.0.1, and different hardware as well.


#80

Hello all, I´m new here and I have done a lot of rearches before asking. I have a Playstation Dualshock 3 controller (bluetooth mode),.

My question is that I when I try to run FUSE (ZX spectrum emulator) I don´t know how to assign different keyboad keys to my DS3 gamepad for different games.

I have tried changind the BIND mapping configuration and other option inside FUSE… but I guess that I´m doing something wrong.

Could someone explain me how to do it step by step?. Thanks for your patient!.

Chema