Next shader preset issue


#1

So I have a couple shader presets in my …/shaders folder - hotkeys set to F5 = Previous and F6= Next.

My presets are named as follows:

“1 - PVM.glslp” (Thick Scanlines Baby!) “2 - CRT.glslp” (NTSC + other stuff) “3 - HDTV.glslp” (Just XBR Multipasses) “retroarch.glslp” (Set to “shaders = 0” and marked as ‘read only’)

Whenever I load up a game, it contains no shaders (retroarch.glslp) which is perfect - I want nothing at first. However, when I hit F6 to go to the next shader, it always goes to “2 - CRT” and not “1 - PVM” I can hit F5 to go back and it goes to #1… and when I scroll through them everything is in order (none>1>2>3>none>1>2>3>etc etc)

So, I’ve worked around this by placing a copy of retroarch.glslp as “0 - None.glslp” in the folder… so now it goes to #1 at first… But now while scrolling it has to go through 2 sets of “no shaders” to cycle back around. (none>0>1>2>3)

Obviously it’s not a huge deal, but it’s kind of odd so I thought I’d bring it up in case it’s a bug or something.

For reference - I’m on Windows 10 using one of the nightly builds from last week or so (x64)


#2

Sounds like a minor issue if it still works in the end like you said. Question: why not just set shaders per core and/or game? What is the point of cycling through them?


#3

Yeah this is indeed a minor issue, one that I’ve since worked around by putting “0 - Video” (My shader for ffmpeg core) in that slot. It’s been a while since I ran that set though, (this thread is from over a year ago) currently I’m using:

  • 0 - Video
  • 1 - RF
  • 2 - Composite
  • 3 - Component
  • 4 - RGB

I do use a set shader, everything defaults to “3 - Component” as it’s my favorite preset. The point of cycling though is so I can pick the look that I feel like using on the fly.