No buttons work in game


#1

Hi everyone.

I have RetroArch loaded on my Amazon Firestick. I just updated the latest version 1.6.7.

I have a Snakebyte idoid:con bluetooth controller

The user bindings all take in RetroArch, I’m able to map everything… but every ROM I load, no buttons appear to do anything.

This is my first time trying to load. I’ve searched multiple places and can’t figure out what I’m doing wrong. From what I can tell, this is a supported controller, but that’s the only thing I could think that is wrong with this?

Any help is greatly appreciated. Thank you, Craig


#2

When you first press a button on your pad, does it say “blahblah pad not configured”? And then you go configure it?

If so, try saving an autoconfig profile and then exit RetroArch and come back (you may have to do this process 2x for some unknown reason). It should then say “blahblah pad configured” and whenever you load a game, it should work.

If it was already saying “blahblah pad configured”, I’m not sure what’s wrong.


#3

Hi @hunterk,

No, unfortunately, nothing appears when I hit any button. Just like nothing is recognized.

But the controller works perfectly in the RetroArch menu and during configuration. I do see that “blahblah fire TV remote configured” if I push any buttons on my standard Amazon remote…

After I start a game (using the controller in the RetroArch menu) - the game starts, I get the screens scrolling - just absolutely can’t do anything. Can’t even exit. I have to push the home button on Amazon stick and go force stop the RetroArch application.

Thanks for trying to help, I do appreciate it.

Craig


#4

if controls works in menu but not ingame, this is probably cause by using older commits of retroarch. this has been fixed though in recent versions so kindly check if there are any updates available. if controls works wehn opening quick menu during a game loaded, try to resellect the default controls. if using custom game config, resave them too.


#5

Thanks, @wertz

I believe the latest is the one I loaded. 1.6.7.

Unfortunately, I’m not even able to open up any menus with game loaded. It doesn’t do anything. I have to go and force stop the application to even get my firestick to load RetroArch again.

I appreciate your suggestions though.


#6

i actually mean latest commit, not versions. version can stay the same but there are diffent commits done or specifically git version(check, if you can in Information > System Information), and this related issue was fixed a few commits ago since, i know since i helped diagnosed this.

you can also try to delete retroarch.cfg and retroarch-core-options.cfg to reset everything, and probably also any remap files you saved (/config)


#7

If you want to try a nightly build, you can download it from buildbot.libretro.com and then sideload it onto your device.


#8

What is a “nightly build”?

Thanks, Craig


#9

Thanks @wertz. Gotta do some running today, but might get around to testing this this evening.

Ya’ll are very helpful. I appreciate all responses.

Have a great Sunday


#10

looked it up and I have 51581e1

I’ll check around see if I can find a newer one. If you happen to see this and don’t mind to point me toward the right location to update my git version, I’d appreciate any pointers.

Thanks again everyone, Craig


#11

I went to the nightly builds from above, downloaded the latest 2017-10-22 apk – my git version didn’t change. I also tried updating using the included update tools in RetroArch with no changes.

My git version is still 51581e1, build date is Mar 10, 2017 if that means anything too.

I also wonder if I’m maybe not using the correct SNES emulator? The core I choose and am running is the: SNES / Super Famicom (Snes9x)

Would that be the correct emulator?

Thanks again everyone… sorry for all the questions!!
Craig


#12

you probably must need to uninstall existing retroarch and reinstall instead. use F-Droid to install retroarch.


#13

It does now say “100% idroid:con configured in port #0:slight_smile:

I don’t think it was saying that before. But, still nothing when actually trying to play a ROM.


#14

i have the same problem with 2 sets of usb cheap gampads, and find the only way to get them to be recognized in game, is to plug and unplug them 3 or 4 times, this is using the lastest nighlys , does anybody know what could be causing it?


#15

Hello there I’m having the same problem. Did you ever find a fix. Im using the new fire tv 3rd gen i believe and using a bluetooth controller that works with everything else. Please let me know if there is a fix.

Thanks


#16

I have the same problem, did you manage to fix it?