No controller input - Linux


#1

Somehow related as if that worked for me it could solve my problem too…

I couldn’t create a new post anyway because i’am new on this forum !

So i explain (and if a moderator see this, he may create a new post for me if he wanna) my own problem : I have a NAS Asustor with a retroarch app installed :

Here’s what some command give for the linux version of the OS :

[email protected]:/volume1/[email protected] # uname -a
Linux AS5102T-A5CD 4.4.24 #1 SMP Fri Nov 23 00:38:21 CST 2018 x86_64 GNU/Linux
[email protected]:/volume1/[email protected] #  cat /proc/version
Linux version 4.4.24 ([email protected]) (gcc version 4.6.4 (crosstool-NG crosstool-ng-1.22.0 - x86_64 64-bit toolchain - ASUSTOR Inc.) ) #1 SMP Fri Nov 23 00:38:21 CST 2018

When i plug my USB controller (a retrobit SNES usb device), here is what i see in /var/log/message

2018-12-19T06:48:31.345502+01:00 AS5102T-A5CD kernel: [228863.340104] usb 1-1.4: new low-speed USB device number 7 using xhci_hcd
2018-12-19T06:48:31.440736+01:00 AS5102T-A5CD kernel: [228863.435511] usb 1-1.4: New USB device found, idVendor=0810, idProduct=e501
2018-12-19T06:48:31.440768+01:00 AS5102T-A5CD kernel: [228863.435518] usb 1-1.4: New USB device strings: Mfr=0, Product=2, SerialNumber=0
2018-12-19T06:48:31.440773+01:00 AS5102T-A5CD kernel: [228863.435522] usb 1-1.4: Product: usb gamepad           
2018-12-19T06:48:31.440784+01:00 AS5102T-A5CD kernel: [228863.435722] usb 1-1.4: ep 0x81 - rounding interval to 64 microframes, ep desc says 80 microframes
2018-12-19T06:48:31.444739+01:00 AS5102T-A5CD kernel: [228863.439425] input: usb gamepad            as /devices/pci0000:00/0000:00:14.0/usb1/1-1/1-1.4/1-1.4:1.0/0003:0810:E501.0006/input/input23
2018-12-19T06:48:31.447505+01:00 AS5102T-A5CD kernel: [228863.442672] hid-generic 0003:0810:E501.0006: input,hidraw2: USB HID v1.10 Joystick [usb gamepad           ] on usb-0000:00:14.0-1.4/input0

But i can’t configure it in retroarch, i tried different input driver or input setting with no success for now, can i have some help debugging the problem ?

The joypad work on the latest retroarch on my PC under W10.

Sorry for my poor english as it’s not my natural language…


Autoconfig controller controls both player one and two!
#2

Ha, that’s pretty cool.

I would probably try linuxraw for the driver. So, with that selected, if you go to settings > input > p1 input binds (using a keyboard), will it let you bind buttons in there?


#3

Thank you for your help ! I try linuxraw (both in input driver an joypad driver) then go to input > user 1 > bind b button > ok but it doesn’t seem to take the joypad press (5 s after, it’s stille the z button of the keyboard). For your information RetroArch seems to be in 1.5.0 version (build may 22 2017) and i read somewhere that there was a problem with user owner of the input, but not sure if it’s my problem, if i am doing something wrong or if my justpad is just not linux friendly…


#4

permissions should only come into play with the udev driver, but here’s the process for setting them up anyway: https://docs.libretro.com/guides/input-joypad-drivers/#setting-up-udev-permissions

You might try doing that process and then switch over to udev and see if it treats you any better.


#5

I think it’s gonna be tricky, i ignore who’s user is gonna be for portal and/or retroarch app…

Maybe i can find out with a top under SSH when i launch RetroArch inside the portal but it’s starting to get a litlle complicated…