No Sound on any game on my computer


A site I trust had the d3dx9_43.dll file, I just copied it into windows/system32 where the other DirectX file are usually installed.


Becausethe one on MS says webinstaller


Can you try installing directx 9.0c using this installer?


I’ll try in the morning


You should use the official webinstaller and not some randomly uploaded dll download from unknown sites


As far as i know you can mute or un-mute everything by pressing strg + m plus you can also mute all players by simply pressing streg + t . I thought i would share because this might come in handy in the near future.


I’ve just recently downloaded RetroArch on a Windows 10 PC. Tried playing several games and have not been able to get the audio to work. Tried the steps listed above, nothing. Even tried uninstalling everything. Made a log for you.

Edit: After another uninstall the sound finally started working. I haven’t figured out what was causing it in the first place.


how many times did u reintsall?


I ended up reinstalling three times.



I’ve installed RetroArch Version 1.7.5 on an Alienware laptop with Windows 10 but I have no audio. I did most of the troubleshooting I’ve found online with no luck. I did the log.txt file and I’m hoping you can help. I’m not sure if I can paste the whole txt here so I only copied these lines where it mentioned Audio:

“[SDL audio]: Requested 64 ms latency, got 85 ms [WARN] Audio rate control was desired, but driver does not support needed features”

My laptop info is: Operating System: Windows 10 Home 64-bit (10.0, Build 17134) (17134.rs4_release.180410-1804) System Model: Alienware 17 R5 BIOS: 1.2.1 (type: UEFI) Processor: Intel® Core™ i7-8750H CPU @ 2.20GHz (12 CPUs), ~2.2GHz Memory: 16384MB RAM DirectX Version: DirectX 12


Hi all

I just posted a reply on this thread asking for help on solving a “no audio” problem with RetroArch. After the post I kept trying different audio drivers and then running the log file and looking for audio errors. After selecting openal driver and ran the log file I didn’t see any errors in the log and the sound started working.

I hope this can help someone else.

Thank you!


I changed the audio driver to “openal” under settings / driver / audio. This helped me. Thank you.