No Sound on any game on my computer


#1

Hi everyone,

I install RetroArch on my computer. When I load a content, I can play but I don’t have any sound…

Do you know how i can activate it ???

Thank you in advance.


#2

Check settings > audio and make sure audio is enabled, not muted, etc. If that checks out, try the different audio drivers in settings > drivers. Also make sure that RA isn’t muted in the windows mixer (systray icon).

If none of that works, send us a log of you opening RA, loading a game, and quitting. It might be able to explain the lack of audio. To get a log, run this on a command line in your RA directory (without the quotes): “retroarch_debug.exe --menu --verbose --log-file log.txt”. This might not work in a write-protected folder like Program Files (write-protected folders can cause other problems too; it’s best to put your RA install folder in your user directory, desktop, documents, etc. to avoid them). The log should be saved in log.txt in your RA directory.

Also, try several cores if you haven’t already, to make sure the problem is RA-wide.


#3

Hi thank you for your answer. I will need more explanation, sorry, i am a newbe :slight_smile:

Setting audio --> yes, I check, everything is ok audio driver --> I do not know what to check… There is lot of options… can you give me your configuration…? Where can I see the systray icon??? How do I “run this on a command line in your RA directory (without the quotes): “retroarch_debug.exe --menu --verbose --log-file log.txt”.” ??? Do I have to be in linux? I am on windows… (real newbe, sorry for that)

Thank you again


#4

The audio driver setting is located in settings > drivers (top of the list in the settings tab). In the drivers menu, you can choose what driver RA uses for video output, controller input, video recording, etc.—as well as audio output. Just try switching the audio driver to the next one in the list (use left and right), quit and restart, and see if it makes a difference. If none of them work, just put it back to the default one while you try the other stuff.

The system tray is in the bottom right corner in windows. It has the date and time as well as a few icons. The volume one (speaker icon) lets you change the volume of individual programs if you click it and then pick “mixer” (unless they changed it in Win10, but you can just google it if so). I’ve accidentally muted programs before with it, and forgotten about it. It’s tricky that way :slight_smile:

Windows does have a command prompt (so does Linux ofc, also Mac OS). On windows, the easiest way to run the command is to open a normal windows explorer window and open your RA folder. Then hold shift and right click in the window (not on a specific file, you might need to make the window wider). Then just copy and paste the command into the window. Note that you need to paste from the right-click menu, as ctrl-v does not work in the command prompt. It should open RA like normal, so just run a game and then quit. There should be a file called log.txt in your RA directory now; just open it to make sure it’s not blank before uploading it.

One piece of advice: feel free to tweak any settings you like. You’re just getting started, so you don’t need to worry about losing your config or anything. If you really screw up your settings and can’t open RA or something like that, just delete retroarch.cfg. The next time you open RA, it will make a new one with all the default settings and you’ll be back to normal. So experiment! (You can also just make a backup copy once you find some settings you want to keep).


#5

[QUOTE=Mr. Figs;52322]The audio driver setting is located in settings > drivers (top of the list in the settings tab). In the drivers menu, you can choose what driver RA uses for video output, controller input, video recording, etc.—as well as audio output. Just try switching the audio driver to the next one in the list (use left and right), quit and restart, and see if it makes a difference. If none of them work, just put it back to the default one while you try the other stuff.

The system tray is in the bottom right corner in windows. It has the date and time as well as a few icons. The volume one (speaker icon) lets you change the volume of individual programs if you click it and then pick “mixer” (unless they changed it in Win10, but you can just google it if so). I’ve accidentally muted programs before with it, and forgotten about it. It’s tricky that way :slight_smile:

Windows does have a command prompt (so does Linux ofc, also Mac OS). On windows, the easiest way to run the command is to open a normal windows explorer window and open your RA folder. Then hold shift and right click in the window (not on a specific file, you might need to make the window wider). Then just copy and paste the command into the window. Note that you need to paste from the right-click menu, as ctrl-v does not work in the command prompt. It should open RA like normal, so just run a game and then quit. There should be a file called log.txt in your RA directory now; just open it to make sure it’s not blank before uploading it.

One piece of advice: feel free to tweak any settings you like. You’re just getting started, so you don’t need to worry about losing your config or anything. If you really screw up your settings and can’t open RA or something like that, just delete retroarch.cfg. The next time you open RA, it will make a new one with all the default settings and you’ll be back to normal. So experiment! (You can also just make a backup copy once you find some settings you want to keep).[/QUOTE]

Hi,thank you for being that patient with me :wink: Problem is solved, I install directX on my computer and now everything is working!!! (I think I didn’t have audioX …)

Thanks again! Anne-Sophie


#6

Glad it works! Enjoy using Retroarch.


#7

Hey there, I’m having the same issue and have tried all the tips in this thread and cannot get my sound working.

When I run the log, I get this error msg:

(Now I used Windows 10 Powershell, that’s the same thing right??)

Funny thing is, RetroArch worked fine on my old computer. I just upgraded my 14-year-old pc to a brand new intel i7700k quad-core, geforce 1070 card… and I can’t believe that Sega Saturn games are running flawlessly! N64! Flawless! The toughest of the tough to emulate… they all play great!

Only thing… no sound.

Any emulator, I’ve tried about a dozen now, going through RA does not work. Not sure where I’m going wrong here.

I’ve got a Logitech 2.1 speaker system. It was kinda funky to set it up to the new machine. I’m thinking that’s the issue.

Now, granted… I’ve got a ton of other emulators from console to mame and the sound works fine. Running natively, like Project64 or ePSXe… everything works fine. All my other emulators work fine.

Just the issue with RetroArch… via Launchbox.

Any help would be appreciated. Thx!


#8

you are using powershell. running programs from the current folder should be for example retroarch: “.\retroarch_debug”,


#9

Ok thanks for the tip…

Here’s the log, broken into 3 parts.


#10

your resampler is set to NULL… set SETTINGS > DRIVER > AUDIO RESAMPLER to sinc, cc or nearest (with sinc being the default)


#11

Boom!

Thanks so much!! Switched to “sinc” and sound works perfectly now.

And holy smokes!! Beetle Saturn is amazing! I can’t believe it, perfect emulation. Mupen64Plus too, all the others… still working on tweaking Dolphin and Citra. Finally part of the pc master race and I’ve got so much to learn. :slightly_smiling_face: Really love RetroArch, thanks again for your help!!


#12

good to know its working now…


#13

I’m also struggling with no audio. It’s only showing audiox as a driver, and it’s not showing on the systems tray… The last bit worries me… first had a problem with DirectX, got the dll and put it in the folder, now I just need the sound… oh and it there a way to play the gba via lan? I know vba was working on it


#14

No GBA netplay currently, but maybe in the future via mGBA.

For your audio, you could try using another driver than xaudio, like wasapi or dsound, openal, etc.


#15

How do I do that? Sorry, I’m just not sure… the PC is offline… must it be online to install the other driver, or can I manually install it,I’ve always used offline installers


#16

The drivers are built-in. Just cycle through them in that menu and restart RetroArch after changing each time.


#17

I tried it just shows audiox, I have 2 computers, I installed it on the other one and the audio works… is there a DirectX audio that maybe might help? I appreciate your help and patience with me… oh in case you wondered, the roms I use are sega, snes, nes, n64 and gba. I have audio when I use my old emulators fceux, vbalink, project 64, gens32surreal and bsnes. Why is RetroArch not showing on my mixer in the systems tray? On the PC I am struggling with?


#18

xaudio is directx’s modern audio API. daudio is the old one (analogous to dinput for input). You should have both of those and a lot more. What version of RetroArch are you using and where did you get it?


#19

1.7.0, I was reading about it on a different site, howtogeek or something similar, but then I Googled to get it from the original site, libretro… I don’t download stuff from just anywhere.


#20

No worries, I just wanted to make sure you weren’t using some super-old version that didn’t have any of the more recent drivers.

So, when you installed directx, how did you do it? did you use the web installer from MS?