Noob troubleshooting: Can't use analogue input in PCSX ReARMed

Apologies if this is a simple fix I haven’t found.

I’ve recently had a hankering for some Gran Turismo 2, so I downloaded RetroArch, and installed the PCSX ReARMed core.

I’m using a Dualshock 3 wired into my PC + SCP to make it work.

The game runs fine, and most controls work as intended, but it does not seem to detect any analogue inputs. The in-game menu has a section for analogue inputs, but it’s greyed out with all options listed as N/A.

EDITED to remove link to copyrighted file. Please don’t do this anymore.

and extracted ps-22a.bin (according to the README in the BIOS zip folder) to RetroArch->config_.system and set the BIOS/system directory to same. However, when the game boots, it says no BIOS found. Again, the game seems to run fine in HLE (no BIOS), but I don’t know if that might be causing my problem.

Thanks for reading.

tl;dr DS3 analogue sticks not working and I don’t know why

Here’s the info for the BIOS:

Also, I believe you’ll need to go to quick menu > core options (while content is loaded) and change the control device type to dual shock.

1 Like

you will sometimes need to restart/reopen core as well after changing the input type. sometimes make sure to disable multiplayer as well

1 Like

Update: analogue control is now working, after switching to beetle core. I’ve done some more fiddling with the BIOS files but I can’t get it to work, however HLE seems to be doing fine.

if its just GT2, both arcade and simulation modes should have analog sticks working… but i am using xbox 360 controller…

Hello. Is there some news ? I have the same problem similar like this : T.Y.

I did get it to work, as I said in my reply further up this thread, but it’s been three years so I can’t remember exactly what I did. It looks like I just ended up using beetle core instead of PCSX ReARMed.

I’m using a raspberry pi 2. Pcsx rearmed is the most stable and functional plugin except for GT2.

I see. In that case, I’m afraid I can’t be of much use to you.