Nvidia Shield Portable - no controls on PCSX-ReArmed

Yeah I know the Shield Portable is old. But I’ve been playing with it and I noticed one thing. With the PCSX-Rearmed core there is no controller input. All of the 12 other cores I have installed work fine. With PCSX-Rearmedt the games load fine with but it’s just that I can’t intereact with them.

This is on Retroarch build date 19 June 2020. Oh and the Shield Portable is rocking Android 4.4. Not sure what other information to give as I don’t post here much. I have googled around a good bit and not found anything useful though.

I have just registered to post after seeing this, sadly I can’t offer much help but I too am having this issue on my 2017 Nvidia Shield with the official Nvidia Controller.

Latest version of RetroArch (1.8.9), with updated Core and Controller profiles. Works fine in the Menu and on other Cores, just not PCSX-Rearmed. Used to work just fine but this is the first time I’ve updated it all since the hacking incident.

If anyone knows of any log or files I can share to help diagnose and help resolve this let me know!

I don’t think this is just a Nvidia shield issue as the last update made to the PCSX Rearmed core (r22 15cfb55) broke controls on Android 8.1 (Retroid Pocket 2) and PC for me so controls are probably broken on all systems that got the updated core. The controls worked fine on both systems before running update all cores a few days ago. I tried changing the input device type from standard to both analog and dualshock but that didn’t fix anything.

Yep tried an older core from August and it works fine. I hadn’t turned my Shield Portable on in years and thought it was a problem with the device. Thanks.

I figured out how to fix the problem. Go into core options, turn on Show other input settings, restart the core, go back to core options, you should now see more input settings, set both Multitap 1 & 2 to off, restart the core one more time, and controls are working again.

Yes works a treat! Good sleuthing on your part sir!