NVIDIA Shield TV - Simultaneous button presses bug

controller
retroarch

#1

Hi. So I recently got myself an Nvidia Shield TV, and installed RetroArch on it. Generally everything runs great on it, except that there’s one niggling problem that has rendered it more or less useless for me.

Every game I’ve tested on it using whatever game core it might be, pressing two buttons simultaneously do not work like most of the time. I started noticing it when I was playing Street Fighter Alpha 3 on the PSPP core, then later found the same problem occurring in MAME too.

I’ve tried to look for a solution in the forums but haven’t had any luck so far?

Has this issue been fixed? I’d love to know, otherwise playing games via RetroArch is nigh on hard since a lot of games rely on simultaneous button presses.


#2

I’ve had trouble with FBA and MAME with CPS (also NEOGEO, but don’t remember everything I tried).

I know I tried different versions of FBA and MAME, and the 64-bit version of Retroarch.

I was mainly testing it with SFZ2A. Supers with 2-3 buttons usually didn’t work. Negative edge (holding buttons then release) didn’t seem to help.

The Run-Ahead feature can help, but there’s some noticeable visual weirdness with it. Some cores don’t run well at all with it on. Run-Ahead settings

The only thing I found that seemed related to this issue was was from 2016.

I tried these controllers:

  • A wireless “gen 1” DualShock 4
  • Fighting Commander for PlayStation 4 & 3 USB controller (mode settings didn’t seem to matter, but I usually leave it in PC and d-pad)
  • SLS Sega Saturn USB controller