Odd CRTResSwitch Behavior with Mupen Next

CRTResSwitch is working pretty much flawlessly for me these days. 31Khz CRT connected on my Windows 10 setup, with modelines installed via CRU (instead of CRT EmuDriver). I’m launching games on a dual-monitor setup. The CRT is set as my primary.

This works for every system except for N64 via Mupen Next. With that system it will change the monitor’s resolution to the required 1920x240 @120Hz, but RetroArch shows up covering the left side of the CRT, and is stretched well below the bottom of the image. Essentially I can only see the top of Mario’s hat in SM64 when it loads.

If I disable my 2nd monitor and ‘only’ load from the CRT it works. If I change my CRT’s default resolution from 1280x960 to one of the 1920 super resolutions it works with both monitors on.

It only seems to be this particular configuration, with this particular core, that is giving me issue. Does anyone have any idea what might be causing that? I’ve been unable to think of any settings that might do it. I even cleared out the mupen entries from /config and the core options config to see if it was something I had messed up, but no dice.

That is an odd one. I don’t know when I can set up a windows test bench to bug test it but I will add it to my list!

What happens if you try to use other superers like 2560/3840?

1 Like

Sadly I’ve never been able to get any other Super-Res to work with this CRT. Even when I tried CRT-EmuDriver I couldn’t go past 1920 for width.

I was gonna take a screenshot for reference and post it here… but I just went to replicate the issue (as I’ve done dozens of times over the past few days)… and sure enough it’s just magically working now. I haven’t changed anything so I don’t know why it’s suddenly working tonight.

Not sure if it makes any difference, but Mupen seems to take forEVER to load a rom for me with CRTResSwitch turned on or off either way. I was thinking maybe something in that long pause was causing issue - but now it wants to play nice tonight so who knows.

I’ll keep screwing with it to see if I can get it to come back… but god that’s so frustrating lol

@Alphanu

I knew I wasn’t crazy. I knew it! lol I haven’t updated RA or changed a core setting or anything, and it started happening again, exactly as before. Only with Mupen, and only with my CRT as a 2nd screen, set to primary.

Here’s the screenshot.

  • Red box is what the game is trying to do.
  • Blue box is what I can see on my CRT.
  • Left is some stupid crap on my normal monitor lol.

This is what my CRT looks like off-screen:

screen