Odd Notifications

Lately, anytime I start a game with RetroArch and press the menu button, I get the three following notifications.

“Waiting for client…” “you have joined as player 1” “port remap failed”

This also makes saving and loading savestates very hit or miss. I usually have to try to save or load 3-5 times before it successfully executes. The thing is, that I’ve disable netplay and saved the configuration. What am I missing?

Anyone have any ideas as to what’s going on?

This sounds like it’s firing a bunch of keyboard events at the same time. Do you have any program like Steam running, by chance?

I do. The next time I’m in my computer, I’ll try closing Steam first and report back. Thanks

@hunterk I tried closing Steam beforehand, but the messages still pop up, unfortunately.

ah man, it wasn’t steam. Guess we can’t blame steam for all our problems after all

I guess not. I’m still having this issue, by the way, and it happens no matter which core I load. I think it must be something in my cfg file. Like, maybe I accidentally mapped the menu button to fire off all this random shit.

if you temporarily move your retroarch.cfg somewhere else, does it stop happening?

I’ll try it tonight and report back. Do I need to move the file first, THEN start Retroarch?

Close RA, move the file, re-launch RA.

Do you have mapped the “Netplay hosting toggle” with the same hotkey as “Menu toggle” ?

Settings -> Input -> Hotkey Binds -> Netplay hosting toggle
Settings -> Input -> Hotkey Binds -> Menu toggle

I don’t recall ever messing with the remap function, but it’s possible. I’ll check that tonight, as well. Thanks for the suggestions, guys.

I tried removing the retroarch.cfg file and all the issues went away. I also checked my hotkey binds, and Netplay hosting toggle was unmapped. Menu toggle was Auto: Guide (btn), (Key: f1).

1 Like

I tried starting with a fresh cfg file, set up everything the way I like it, and the issue popped up again when starting with LaunchBox. If I start Retroarch directly, there’s no problem. Looks like I need to head over to their forums. Thanks for trying to help me out.

1 Like