Older versions of Retroarch for Android 4.x

Hi I have a couple of old Android stick/TV devices, they both run Android 4.0.

If I recall the early versions had the cores installed, so I’m hoping to find an apk for the last version that supported Android 4.x?

I was wondering if anyone knows what the version is and/or where could find it?

I found an old post here but links are down https://libretro.wordpress.com/2013/09/25/retroarch-0-9-9-7-upcoming-progress/

We don’t have any builds that old, AFAIK. I think the farthest back we can support right now is 4.4

I have a Jellybean Tablet, I don’t recall the cores ever being installed with RA there, which was painful because the WLAN sucked and you couldn’t manually install the cores from another source back when I used it. I still have the RA 1.7.5 apk that was last installed there though.

Thanks, to you both, I just checked and one is running 4.4.2, the other 4.04.

@hunterk do you know the version no. that supports 4.4 please?

@Jamirus yeah, both of the android sticks have terrible Wi-Fi (constanlty disconnects) so I was hoping to copy any files I need onto a memory card. I think they are both rooted so could probably copy some cores over.

I guess it depends on what I can get working. I managed to get hold of v1.7.7 but the interface is having issues loading so I think I need an older, or alternative version.

Older versions of RA will not recognize cores that are just copied over.I recall that there was some way around with messing around with the updater url and then downloading it from a different setup url or something. Too much hassle, wouldn’t bother.

1 Like

Have you tried the non-Plus version from the Play Store? I think it should support pretty far back and comes with cores.

1 Like

I have an old phone with 4.0.4, retroarch 1.7.7 or 8 should be the last one supporting it. It updates normally and downloads cores as it should on newer versions. You miss some newer features though.

Thank you all :+1:

I have been testing everything on my RK3188 Q7 - HI718 first (an old Android TV box), I believe it has a Rockchip RK3188-T.

@DariusG I tried 1.7.7 but unfortunately it was too unstable, it also had some issues with the UI.

@hunterk the plus version seems to support Android 5.x and up and I don’t think I have access to the play store on my device anymore so I couldn’t confirm

@Jamirus I do recall messing about with old Mac cores and having issues, so I skipped that idea

I found an archive of older Android versions here: https://www.apkmirror.com/apk/libretro/retroarch/

After the issues with v1.7.7 I then tried all the older versions from that site * phew * and finally discovered that v1.3.6 worked well.

Amazingly the cores do still download so this was a nice surprise. v1.3.6 also supported my keyboard and wireless game pad, and after disabling threaded video I was susprised how smooth everything runs. Very impressive :grin:

Next I will test a lower spec Rikomagic MK802 II Mini PC Android tv stick.


Quick update: I tried the same 1.3.6 version on the Rikomagic MK802 II Mini PC Android tv stick and it worked the same. It ran slightly slower but the same functionality was there :smile: