Outputting to a CRT

Im finally getting around to trying to output everything to a crt. Im running an R9 380 amd card in win 10, a few days ago I installed crt-emudriver, ran vmmaker and set all my custom mode-lines using a guide by cdcruze for setting up retroarch for a crt.

I used his ini. list of super resolutions that groovymame/retroarch would need , I also followed his settings and put retroarch into rgui layout and tried to change the following…

  • settings > User Interface > Show Advanced Settings > On
  • Settings > Driver > Video > d3d11
  • Settings > Video
    • CRT SwitchRes > On
    • Start in Fullscreen Mode > On
    • CRT Super Resolution > 2560
    • Use Custom Refresh Rate > On
    • Windowed Full Screen Mode > Off
    • Config Aspect Ratio > 8.00
    • Custom Aspect Ratio Width > 2560
    • Custom Aspect Ratio Height > 240
    • Bilinear Filtering > Off

I couldnt find the aspect ratio settings in retroarchs config file. Ive had some success , ive got snes and genesis cores to output to my crt tv but badly offcentered to the right. Turbografx 16 just gives me a scrambled screen on the crt so havnt even tried any other cores because I got discouraged as tg16 is one of my favorite systems and cant get it running on the crt.

Im ultimately wanting to navigate launchbox from my lcd and load the roms to the crt. I cant even get groovymame to launch to the crt at all nomatter what I try. If I make crt primary it still outputs to the lcd, if I disable the lcd then mame crashes. Ive tried editing mames config to osd per window video options to \.\DISPLAY2 Mame just crashes. But Ive got a thread about mame going on at arcade controls so dont need help with it…just thought id mention it.

Anyway… back to retroarch. Theres a guy on youtube who is doing what im trying to accomplish. Hes running launchbox on his lcd. When he launches a game with retroarch it shows he has the “launch to retroarch crt” option. How is he getting that option?

Ive got an 8tb launchbox hdd that ive compiled over the years. What all emulators will I be able to run on the crt? Will I need to setup retroarch to handle all emulation instead of using standalones for output to my crt to be possible? Im currently using retroarch for all 8bit and 16bit cores but in order to get ps1, saturn, etc to run on the crt do I need to reconfigure my launchbox setup to have retroarch run all these systems? Is there a list somewhere of what all systems retroarch can handle?

Sorry for all the noobish questions. I was deep into all this years ago when I built my arcade cab but have forgotten alot. Any other help, advice, suggesstions getting this up and running? Thanks!

Ok so… Calamity straightened me out over on arcadecontrol forums. I had the right version of groovymame but not the d3d9ex version. Once I ran the right version I have mame running and looking amazing! But the games are running too fast but im looking into that now…

The real concern is if ill get everything running right in retroarch. Some of the later gen stuff ill run off the lcd but saturn, ps1 gen stuff and prior I want to run from ra at least. Any ideas why tg16 looks out of sync? I added these modelines for consoles, am i missing tg16 res?

  • 2560 x 192 @ 60.000000 retroarch
  • 2560 x 200 @ 60.000000 retroarch
  • 2560 x 240 @ 60.000000 retroarch
  • 2560 x 224 @ 60.000000 retroarch
  • 2560 x 237 @ 60.000000 retroarch
  • 2560 x 256 @ 50.000000 retroarch
  • 2560 x 254 @ 55.000000 retroarch
  • 2560 x 448 @ 60.000000 retroarch
  • 2560 x 480 @ 60.000000 retroarch

Is there any current guides or suggested settings to get ra running on a crt? Any other suggestions or advice?
Thanks!

So once I ran launchbox on the crt instead of the lcd…everything started working. But im not sure if the emulators/cores are running in 480i or actually using the mode-lines to go 240p-ish. Mame looks crisp and nice scanlines but what I run in retroarch looks good but soft. How can I check to see what res the roms are running under?

Looks good! That’s clever using an ultrawide for the marquee.

For your question about softness, try disabling bilinear filtering in settings > video.