Parallel core crashes RetroArch (Vulkan drivers)

Hi everyone,

I just tried the new Parallel core on RetroArch 1.8.6 32bit and I’m experiencing an odd issue. When using Vulkan drivers on RA, Parallel crashes it at whatever N64 game I boot, if I set GFX plugin and RSP plugins to Parallel. No problem with other combinations, for example Angrylion + CDX4. RA seems to recognize my GTX 1060 no problem and my GameReady drivers are updated (same with Windows10).

I must say I’m not confident at all with N64 emulation on RA - this is my first time tinkering about it - but I can tell the sound isn’t right either, as it changes pace - going from normal to slow to fast - and crackly at times.

Do you guys have any suggestion? Thanks in advance!

Try with parallel-n64-disable_expmem = "enabled"

Thanks for replying!

I just checked and it was already set to ‘enabled’ in the RA core options config file.

Update, as it all seems to work fine, with RetroArch 1.8.6 64bit, instead of 32. No crashes with Vulkan and Parallel, and sound is fine with no crackling. I only tried two games - Beetle Adventure Racing! and Killer Instinct Gold - but so far so good.


It’s crashing for me, I think it depends on 3 things, games, the disable_expmem setting, the framerate setting, and whether if using shaders or not.

With shader (works without it) errors out with a:

[ERROR]: vkQueueSubmit failed (code: -4).
[ERROR]: Failed to wait for timeline semaphore!
[ERROR]: vkDeviceWaitIdle failed with code: -4
Exception code=0xc0000005 flags=0x0 at 0x000000001224F8C0. Access violation - at
tempting to read data at address 0x00000000000016C0

With one of the above settings at the wrong value:

[libretro INFO] EmuThread: M64CMD_EXECUTE.
Gfx RomOpen.
[ERROR]: Failed to allocate RDRAM.
[libretro ERROR] This device probably does not support 8/16-bit storage. Make su
re you're using up-to-date drivers!
Exception code=0xc0000005 flags=0x0 at 0x0000000064942EC9. Access violation - at
tempting to read data at address 0x00000000000012A8

Is there any nvidia o vulkan driver minimum requirement?

EDIT: updated to last version and it seems to be fixed