PCSX-ReARMed Core Keeps Crashing?


Any time I try to load a game on the PCSX-ReARMed core (r23l c288fa8) from RetroArch 1.10.3, it’ll crash and close.

Any suggestions on fixing this issue? Unfortunately, my computer is not able to handle any other PS1 emulator.

Many thanks in advance!

–I am running Windows 8.1 (64-bit); plus have done a fresh re-install of RetroArch, then made sure the ‘scph5501.bin’ bios are in the right system folder, if this helps.

I’m not a pcsx rearmed user, I know it can work without bios but it might have compatibility problems try different bios.


Also try to use different video drivers: glcore/vulkan/d3d/gl

1 Like

I have tried the EU & JP bios, plus the different video drivers listed; nothing changes.

Also my computer only supports the ‘gl’ video driver.

Why bother using some ARM-targeted core with Windows though?

I had the same problem on Windows. Open the PCSX-ReARMed.opt file and disable the Dynamic Recompiler. pcsx_rearmed_drc = “disabled”

I tried this solution & it seemed to fix the issue. :grin:


1 Like